Secure Connect Gateway: Policy Manager-Einstellungen können nicht geändert werden, weil das Konto gesperrt ist
Summary: In diesem Artikel wird eine Situation beschrieben, in der die Policy Manager-Einstellungen auf der Benutzeroberfläche nach einer Kennwortänderung in Policy Manager nicht geändert werden können. Auch das Zurücksetzen der Secure Connect Gateway Lockbox. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Die Benutzeroberfläche des sicheren Verbindungsgateways zeigt beim Versuch, Policy Manager zu ändern oder zu deaktivieren, die Meldung "Unknown Error" an und kann Folgendes nicht speichern:
Die Benutzeroberfläche von Policy Manager ist gesperrt:
From /var/lib/docker/volumes/esrslog/_data/var/log/esrs/policymanager.log (Error code 423, text "User account is locked"):
ERROR com.dellemc.iot.platform.pmc.service.pm.PolicyManagerInteractionService [http-nio-7778-exec-9, 559af94c-d8ae-48ee-8c49-c7ad28c81564, ] Got exception from server error code is 423, and error text is User account is locked.
ERROR com.dellemc.iot.platform.pmc.controller.advise.PolicyManagerControllerAdvice [http-nio-7778-exec-9, 559af94c-d8ae-48ee-8c49-c7ad28c81564, ] Error for {}
com.dellemc.iot.platform.pmc.exception.PolicyManagerClientException: Something went wrong at Backend. Please try after sometime.
Die Benutzeroberfläche von Policy Manager ist gesperrt:
Cause
- Das Policy Manager-Kennwort wird geändert, ohne zuerst die SCG-PM-Verbindung zu deaktivieren.
- Secure Connect Gateway-Lockbox wird während des Upgrades oder der Fehlerbehebung zurückgesetzt
Resolution
1. Melden Sie sich mit SSH bei Secure Connect Gateway an und geben Sie den folgenden Befehl aus:
2. Überprüfen Sie auf der Secure Connect Gateway-Benutzeroberfläche, ob die Policy Manager-Einstellung gelöscht
wurde,3. Warten Sie, bis die Sperrzeit der Policy Manager-Benutzeroberfläche abgelaufen ist, und vergewissern Sie sich, dass die Policy Manager-Anmeldung funktioniert,4
. Konfigurieren Sie die Policy Manager-Einstellung auf Secure Connect Gateway neu.
Pre 5.16: # docker exec -u postgres esrsde-app psql -U postgres -d vapp -c 'delete from policy_manager_config' Post 5.16: # docker exec esrsde-app psql -U postgres -d vapp -c 'delete from policy_manager_config'
2. Überprüfen Sie auf der Secure Connect Gateway-Benutzeroberfläche, ob die Policy Manager-Einstellung gelöscht
wurde,3. Warten Sie, bis die Sperrzeit der Policy Manager-Benutzeroberfläche abgelaufen ist, und vergewissern Sie sich, dass die Policy Manager-Anmeldung funktioniert,4
. Konfigurieren Sie die Policy Manager-Einstellung auf Secure Connect Gateway neu.
Additional Information
Wenn der folgende Fehler auftritt, verwenden Sie den Befehl Post 5.16.
# docker exec -u postgres esrsde-app psql -U postgres -d vapp -c 'select * from policy_manager_config'
psql: error: connection to server on socket "/var/run/postgresql/.s.PGSQL.5432" failed: FATAL: Peer authentication failed for user "postgres"
Affected Products
Secure Connect Gateway - Virtual EditionArticle Properties
Article Number: 000205944
Article Type: Solution
Last Modified: 17 Jul 2024
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.