NVP vProxy: NetWorker nsrvim process runs every 15 minutes causing a high workload on vCenter Server and potential VPXD unavailability
Summary: The VMware vCenter server is observing VPXD service unavailability or is unresponsive due to high workload from NetWorker server. This KB provides details on how to tune the NetWorker vCenter inventory discovery process (nsrvim). ...
Symptoms
- The NetWorker server has been configured for VMware protection of a vCenter server.
- The vCenter server observes issues with the VMware Virtual Provisioning X Daemon (VPXD) service availability or general high workload.
Cause
NetWorker's vCenter inventory process (nsrvim) is initiated during service startup then runs every 15 minutes (default). This process also runs anytime a VMware protection job runs against the vCenter. Depending on how many NetWorker servers are connected to the vCenter, and the amount or frequency of VMware protection policy operations. This causes several inventory query requests against the vCenter server in a short window.
This task is observed in the daemon.log on the NetWorker server as:
106637 MM/DD/YYY HH:MM:SS AM/PM 1 3 0 15204 8080 0 NSR_HOSTNAME nsrdisp_nwbg RAP notice job 'nsrvim' progress message: nsrvim starting on NSR_HOSTNAME (process 10852).
106637 MM/DD/YYY HH:MM:SS AM/PM 1 3 0 15204 8080 0 NSR_HOSTNAME nsrdisp_nwbg RAP notice job 'nsrvim' progress message: Connecting to NetWorker on 'NSR_HOSTNAME'.
106637 MM/DD/YYY HH:MM:SS AM/PM 1 3 0 15204 8080 0 NSR_HOSTNAME nsrdisp_nwbg RAP notice job 'nsrvim' progress message: Querying NSR hypervisor resource 'VC_HOSTNAME'
106637 MM/DD/YYY HH:MM:SS AM/PM 1 3 0 15204 8080 0 NSR_HOSTNAME nsrdisp_nwbg RAP notice job 'nsrvim' progress message: Connecting to service at https://VC_HOSTNAME/sdk
106637 MM/DD/YYY HH:MM:SS AM/PM 1 3 0 15204 8080 0 NSR_HOSTNAME nsrdisp_nwbg RAP notice job 'nsrvim' progress message: Starting session with infrastructure services daemon.
106637 MM/DD/YYY HH:MM:SS AM/PM 1 3 0 15204 8080 0 NSR_HOSTNAME nsrdisp_nwbg RAP notice job 'nsrvim' progress message: Querying for inventory at https://VC_HOSTNAME/sdk
106637 MM/DD/YYY HH:MM:SS AM/PM 1 3 0 15204 8080 0 NSR_HOSTNAME nsrdisp_nwbg RAP notice job 'nsrvim' progress message: Querying for categories from infrastructure services daemon.
106637 MM/DD/YYY HH:MM:SS AM/PM 1 3 0 15204 8080 0 NSR_HOSTNAME nsrdisp_nwbg RAP notice job 'nsrvim' progress message: Updating NSR hypervisor resource 'VC_HOSTNAME'
106637 MM/DD/YYY HH:MM:SS AM/PM 1 3 0 15204 8080 0 NSR_HOSTNAME nsrdisp_nwbg RAP notice job 'nsrvim' progress message: Finished updating NSR hypervisor resource 'VC_HOSTNAME'
106637 MM/DD/YYY HH:MM:SS AM/PM 1 3 0 15204 8080 0 NSR_HOSTNAME nsrdisp_nwbg RAP notice job 'nsrvim' progress message: nsrvim exiting on NSR_HOSTNAME (process 10852).
The same messaging appears when a VMware protection policy runs.
Resolution
NetWorker 19.10 has introduced a new feature which allows the NetWorker backup administrator to tune the nsrvim frequency. This functionality was introduced by using a new environment variable on the NetWorker server. To use this environment variable, perform the following:
1. Upgrade the NetWorker server to 19.10.0.0 (or later). https://www.dell.com/support/home/product-support/product/networker/drivers
2. Create the NSRVIM_TIME_INTERVAL on the NetWorker server. Adding or changing this variable requires a nsrd restart. To create the environment variable, perform the following depending on the operating system of the NetWorker server:
Linux:
1. Modify (or create) the file /nsr/nsrrc:sudo vi /nsr/nsrrc
2. Add the following lines to the file:
NSRVIM_TIME_INTERVAL=60
export NSRVIM_TIME_INTERVAL
3. Restart the NetWorker server services:
sudo systemctl restart networker
Microsoft Windows:
1. Open Control Panel, then click System and Security, then click System.
2. Click Advanced System Settings.

3. From System Properties, click Environment Variables.
4. Under System Variables, click New:

5. In the Variable Name field, enter: NSRVIM_TIME_INTERVAL
6. In the Variable Value field, enter a number from 15 to 60 (this number corresponds to minutes).

7. Reboot the server.
Additional Information
- NVP vProxy: Large number of sessions causing the vCenter's VPXD service to fail or run out of HTTP sessions.
- NVP vProxy: VM backups failing with "Unable to fetch data from vCenter: HTTP Error"
- NetWorker: VMware View Refresh Fails "Dispatcher Request Timed Out"
- NetWorker: VMware groups failing with error failed to load inventory from vCenter