NetWorker: restapi.log файл не генерується на сервері NetWorker, розгорнутому на кластері кардіостимуляторів Red Hat
Summary: restapi.log файли не генеруються на сервері NetWorker, розгорнутому на кластері кардіостимуляторів Red Hat.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
- Сервер NetWorker розгорнутий на кластері Red Hat HA (кардіостимулятор).
- Журнали інтерфейсу прикладного програмування (API) з передачею представницького стану (REST) під журналами /nsr/logs/restapi не створюються.
Cause
Спільний диск не зіставляється з журналом REST API.
Resolution
- Увійдіть в активний вузол від імені root.
Активний вузол може бути показаний з:
pcs resource show
Приклад:
root@NWrhelNodeC:~# pcs resource show
Resource Group: NW_group
fs (ocf::heartbeat:Filesystem): Started NWrhelNodeC.emclab.local
ip (ocf::heartbeat:IPaddr): Started NWrhelNodeC.emclab.local
nws (ocf::EMC_NetWorker:Server): Started NWrhelNodeC.emclab.local
- Підтвердьте картування, яке використовує кардіостимулятор:
lcmap
Приклад:
root@NWrhelNodeC:~# lcmap
type: NSR_CLU_TYPE;
clu_type: NSR_LC_TYPE;
interface version: 1.0;
type: NSR_CLU_VIRTHOST;
hostname: 192.168.25.40;
local: TRUE;
owned paths: /nsr_share;
- Зробіть копію REST API logback.xml:
cp /nsr/authc/webapps/nwrestapi/WEB-INF/classes/logback.xml /nsr/authc/webapps/nwrestapi/WEB-INF/classes/logback.xml.bak
- Змініть logback.xml так, щоб використовувати абсолютний шлях до каталогу журналів REST API:
vi /nsr_share/nsr/authc/webapps/nwrestapi/WEB-INF/classes/logback.xml
Зміна:
<?xml version="1.0" encoding="UTF-8"?>
<configuration scan="true" scanPeriod="10 seconds">
<contextListener class="ch.qos.logback.classic.jul.LevelChangePropagator">
<resetJUL>true</resetJUL>
</contextListener>
<define name="logdir" class="com.emc.nw.webapi.LogDir"/>
<appender name="file" class="ch.qos.logback.core.rolling.RollingFileAppender">
<file>${logdir}/restapi.log</file>
<encoder>
<pattern>%d{yyyy-MM-dd HH:mm:ss.SSS} %-5level [%thread] %logger{15} - %msg%n</pattern>
</encoder>
<rollingPolicy class="ch.qos.logback.core.rolling.FixedWindowRollingPolicy">
<fileNamePattern>${logdir}/restapi_%i.log.zip</fileNamePattern>
<minIndex>1</minIndex>
<maxIndex>10</maxIndex>
<totalSizeCap>500MB</totalSizeCap>
...
До:
<?xml version="1.0" encoding="UTF-8"?>
<configuration scan="true" scanPeriod="10 seconds">
<contextListener class="ch.qos.logback.classic.jul.LevelChangePropagator">
<resetJUL>true</resetJUL>
</contextListener>
<define name="logdir" class="com.emc.nw.webapi.LogDir"/>
<appender name="file" class="ch.qos.logback.core.rolling.RollingFileAppender">
<file>/nsr_share/nsr/logs/restapi/restapi.log</file>
<encoder>
<pattern>%d{yyyy-MM-dd HH:mm:ss.SSS} %-5level [%thread] %logger{15} - %msg%n</pattern>
</encoder>
<rollingPolicy class="ch.qos.logback.core.rolling.FixedWindowRollingPolicy">
<fileNamePattern>/nsr_share/nsr/logs/restapi/restapi_%i.log.zip</fileNamePattern>
<minIndex>1</minIndex>
<maxIndex>10</maxIndex>
<totalSizeCap>500MB</totalSizeCap>
...
ПРИМІТКА. Переконайтеся, що шлях до спільного ресурсу збігається з назвою спільної папки, яку виводить команда lcmap .
- Створіть папку журналів вручну
mkdir /nsr_share/nsr/logs/restapi
- Змініть власника каталогу на nsrtomcat:
chown nsrtomcat:nsrtomcat /nsr_share/nsr/logs/restapi
- Встановіть дозволи в директорії REST API:
chmod 755 /nsr_share/nsr/logs/restapi
- Перезапустіть кластеризовані сервіси NetWorker:
pcs resource restart nws
- Переконайтеся, що файл restapi.log генерується після запуску ресурсу nws :
root@NWrhelNodeC:~# ls -l /nsr_share/nsr/logs/restapi/ total 7428 -rw-------. 1 nsrtomcat nsrtomcat 7603829 Dec 14 11:01 restapi.log -rw-------. 1 nsrtomcat nsrtomcat 0 Dec 14 10:46 rest_index.raw
Additional Information
Affected Products
NetWorkerProducts
NetWorker Family, NetWorker SeriesArticle Properties
Article Number: 000206436
Article Type: Solution
Last Modified: 24 Mar 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.