PowerEdge: Utilizzare racadm negli strumenti iDRAC da GuestOS-CentOS, RHEL, ESXi-per interagire con iDRAC
Summary: Utilizzo degli strumenti iDRAC per interagire con iDRAC quando non è raggiungibile tramite il web browser. Può succedere che dopo un aggiornamento del firmware iDRAC, iDRAC non sia raggiungibile ma GuestOS sia raggiungibile. In tal caso, utilizzare gli strumenti iDRAC per risolvere il problema e riportarlo online. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Instructions
Sintomi:
iDRAC non esegue il ping o la pagina web iDRAC non si carica.
Causa:
Il ripristino delle impostazioni predefinite di iDRAC o l'aggiornamento del firmware iDRAC possono causare questo problema.
Risoluzione:
-
Scaricare lo strumento iDRAC utilizzando i link riportati di seguito per il rispettivo sistema operativo.
- ESXi 6.5.x: Strumenti Dell iDRAC per VMware ESXi (R), v9.3.1 | Dettagli del conducente | Dell Stati Uniti
- ESXi 6.7.x: Strumenti Dell iDRAC per VMware ESXi 6.7 U3 (R), v10.1.0.0 | Dettagli del conducente | Dell Stati Uniti
- ESXi 7.0.x, ESXi 8.0.x: Strumenti Dell iDRAC per ESXi, v11.0.0.0 | Dettagli del conducente | Dell Stati Uniti
- CentOS, RHEL: Strumenti Dell iDRAC per Linux, v9.4.0 | Dettagli del conducente | Dell Stati Uniti
- Per il sistema operativo ESXi, viene scaricato un file di .zip. Seguire la procedura riportata di seguito per copiare e installare gli strumenti iDRAC scaricati.
- Estrarre il file .zip e accedere al <nome della cartella estratta
>\vib20. - Copiare la cartella racadm nell host ESXi utilizzando lo strumento WinSCP o qualsiasi altro strumento simile in
/tmp. - Eseguire il comando riportato di seguito per verificare se gli strumenti iDRAC (racadm) sono già installati. Se non viene visualizzato alcun output, significa che non è installato.
- Estrarre il file .zip e accedere al <nome della cartella estratta
esxcli software vib list | grep -i racadm
- Eseguire il comando riportato di seguito per installare gli strumenti iDRAC (racadm). L'output indica se è necessario o meno un riavvio.
esxcli software vib install -v /tmp/racadm/<file_name.vib>
- Una volta installato, utilizzare i comandi racadm per ulteriori procedure di risoluzione dei problemi.
- Per il sistema operativo CentOS, RHEL, viene scaricato un file di .tar.gz. Seguire la procedura riportata di seguito per copiare e installare gli strumenti iDRAC scaricati.
- Copiare .tar.gz file sul nodo CentOS/RHEL utilizzando lo strumento WinSCP o qualsiasi altro strumento simile in
/tmpcartella - Eseguire il comando seguente sul nodo per estrarre il pacchetto di strumenti iDRAC in
get.rpmfile
- Copiare .tar.gz file sul nodo CentOS/RHEL utilizzando lo strumento WinSCP o qualsiasi altro strumento simile in
cd /tmp/
tar -zxvf <filename>.tar.gz
- Tutti questi file vengono estratti in una cartella denominata
iDRACTools. Utilizzarels -lcomando per verificarlo.
- Per verificare se gli strumenti iDRAC (racadm) sono già installati sul nodo o meno, eseguire
rpm -qa | grep -i racadm.Se non viene visualizzato alcun output, significa che non è installato. - Ora vai a
iDRACTools/racadmcartella ed eseguiinstall_racadm.shutilizzando i comandi riportati di seguito.
cd /tmp/iDRACTools/racadm
./Install_racadm.sh
- Una volta installato lo strumento, aprire una nuova sessione SSH o disconnettersi dalla sessione SSH ed effettuare nuovamente l'accesso ai comandi racadm per ulteriori procedure di risoluzione dei problemi. Per verificare se il server richiede o meno il riavvio, eseguire il comando
needs-restarting -r; echo $?
- Per verificare se il pacchetto racadm è stato installato correttamente, eseguire
rpm -qa | grep -i racadm. Se elenca il pacchetto, significa che è stato installato correttamente.
- Per verificare le impostazioni di rete correnti di iDRAC utilizzando lo strumento racadm, eseguire il comando
racadm getniccfg. Qui, verificare che i dettagli dell'indirizzo IP siano corretti e se DHCP sia impostato su disabilitato. Vedere la schermata seguente come esempio.
Nota: la sintassi del comando racadm rimane la stessa indipendentemente dal sistema operativo guest.
- Se si nota che i dettagli IP non sono assegnati correttamente o se DHCP è abilitato, utilizzare il comando seguente per assegnare l'indirizzo IP e disabilitare DHCP:
- Per impostare l'indirizzo IPv4:
racadm set iDRAC.IPv4Address <ip_address> - Per impostare la netmask IPv4:
racadm set iDRAC.IPv4Netmask <subnet_mask> - Per impostare un gateway IPv4:
racadm set iDRAC.IPv4Gateway <gateway_ip> - Per disabilitare DHCP:
racadm set iDRAC.IPv4DHCPEnable 0
- Se è necessario reimpostare iDRAC da GuestOS, utilizzare i comandi riportati di seguito:
- Eseguire un soft reset di iDRAC:
racadm racreset soft - Eseguire un hard reset di iDRAC:
racadm racreset hard - Forzare un soft reset di iDRAC:
racadm racreset soft -f - Forzare un hard reset di iDRAC:
racadm racreset hard -f
- Per ulteriori comandi racadm, eseguire
racadm helpoppure, per verificare la presenza di un comando specifico, eseguireracadm <command> help - Ricordarsi di rimuovere iDRACTools (racadm) da GuestOS (ESXi, RHEL, CentOS), soprattutto se è presente una soluzione HCI come PowerFlex, VxRail, così via si consiglia di rimuovere gli strumenti iDRACTools (racadm), altrimenti potrebbe causare un errore di aggiornamento dei nodi con processo automatizzato.
- Per il sistema operativo ESXi:
- Per verificare se iDRACTools (racadm) è installato o meno, eseguire:
esxcli software vib list | grep -i racadm
- Per rimuovere iDRACTools (racadm), eseguire:
esxcli software vib remove -n racadm
- Per il sistema operativo RHEL, CentOS:
- Per verificare se iDRACTools (racadm) è già installato sul nodo o meno, eseguire
rpm -qa | grep -i racadm.. Se non viene visualizzato alcun output, significa che non è installato. - Per rimuovere iDRACTools (racadm) dal nodo, eseguire
uninstall_racadm.shscript che viene fornito con il pacchetto di tar.gz iDRACTools. - Eseguire
uninstall_racadm.shscript, andare alla cartella iDRACTools ed eseguire./uninstall_racadm.sh
- Se il problema persiste, contattare il Supporto Dell per ulteriore assistenza.
Affected Products
iDRAC9, Red Hat Enterprise Linux Version 9, Red Hat Enterprise Linux Version 8, VMware ESXi 7.x, VMware ESXi 8.xProducts
PowerFlex rack, C Series, HS Series, Modular Infrastructure, Rack Servers, Tower Servers, XE Servers, XR Servers, ScaleIOArticle Properties
Article Number: 000206945
Article Type: How To
Last Modified: 24 Sep 2025
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.