Avamar: Oracle Backup channels being disabled during RMAN backups: channel disabled, job failed on it will be run on another channel

Summary: Oracle Backup channels being disabled during RMAN backups channel x disabled, job failed on it will be run on another channel.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Avamar Oracle Backup channels are disabled during RMAN backups.
There are three Oracle clients instances configured to use 15 channels, but only four instances are used during backups.
11 instances are disabled.

Below are examples of errors found in RMAN.log
 
RMAN-03009: failure of backup command on t6 channel at %date%
ORA-19509: failed to delete sequential file, handle="Instance", parms="SBT_LIBRARY=/usr/local/avamar/lib/libobk_avamar64.so,ENV=(ORACLE_HOME=/path/to/db_home"
ORA-27027: sbtremove2 returned error
ORA-19511: non RMAN, but media manager or vendor specific failure, error text:
   getinfo() returned error:-2 labelnum:0 local_error:-1
ORA-27191: sbtinfo2 returned err
channel t6 disabled, job failed on it will be run on another channel
RMAN-03009: failure of backup command on t7 channel at %date%

Cause

This is a configuration issue. 
The path to the client account in the flag file is incorrect;
 
avtar Warning <5498>: Cannot write dispatcher table file /usr/local/avamar/var/client_name-27000.dtb (code 13: Permission denied).
avtar Info <5559>: - Trying connection Utility_node:29000
avtar Info <5560>: - Connected to node Utility_node:29000, Priv=0, SSL Cipher=ECDHE-RSA-AES256-GCM-SHA384
avtar Info <5583>: Login User: "dbarman", Domain: "default", Account: "/domain/client_name
avtar Info <5580>: Logging in on connection 0 (server 0)
avtar Error <5126>: Login error 74: Account not found in the Avamar database
avtar FATAL <5308>: Failed to initiate session with server
avtar Info <6149>: Error summary: 2 errors: 5308, 5126
avtar Info <5314>: Command failed (2 errors, 1 warning, exit code 10008: cannot establish connection with server (possible network or DNS failure))

Resolution

All the flag files on ALL nodes of the cluster should point to the correct account location in Avamar.

Ensure the "--path=/clients/my-db-client" is the correct domain location in Avamar.

Example:
--pidname=Oracle
--pidnum=pidnum
--logfile=install-dir/var/clientlogs/avtar.log
--vardir=install-dir/var/clientlogs
--id=user
--ap=password
--path=/clients/my-db-client

Affected Products

Avamar Plug-in for Oracle
Article Properties
Article Number: 000206965
Article Type: Solution
Last Modified: 09 Oct 2024
Version:  4
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