NetWorker: Active Directory Granular backup fails: Unknown error 0x8000500c

Summary: NetWorker Module for Microsoft (NMM) Active Directory Granular backup fails. The reported error is: Exception: System.Runtime.InteropServices.COMException (0x8000500C): Unknown error (0x8000500c) ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker Module for Microsoft (NMM) Active Directory Granular backup fails. 
The backup reports the following error:

 

Processing child entry LDAP://localhost/CN=Objectname1,OU=level3,OU=level2,OU=level1,OU=Workstations,DC=domain,DC=top

Exception: System.Runtime.InteropServices.COMException (0x8000500C): Unknown error (0x8000500c)
at System.DirectoryServices.PropertyValueCollection.PopulateList()
at System.DirectoryServices.PropertyValueCollection..ctor(DirectoryEntry entry, String propertyName)
at System.DirectoryServices.PropertyCollection.get_Item(String propertyName)
at EMC.NsrAdSave.ActiveDirectoryBackup.ConvertEntry(DirectoryEntry entry)
at EMC.NsrAdSave.ActiveDirectoryBackup.SavePath(LdapPath path)
at EMC.NsrAdSave.ActiveDirectoryBackup.SavePath(LdapPath path)


 

Cause

The root cause of this issue is related to user permissions of the user running the backup.
The issue is that the user is missing read permissions for the Active Directory abstract schema.




 

Resolution

To resolve this issue, perform the following steps:

  • Create a Domain User account with 'Backup Operators' permissions to correctly read the Active Directory abstract schema.
  • Run the NMM Active Directory granular restore with that privileged user.


 

Article Properties
Article Number: 000209226
Article Type: Solution
Last Modified: 10 Feb 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.