VMware: Virtual Machine kunne ikke tændes pga. diskkonsolidering-snapshot-problem

Summary: I denne artikel forklares det, hvordan du løser en situation, hvor en virtuel maskine (VM) ikke kan tændes på grund af problemer med en diskkonsolidering eller et snapshot.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • VM kunne ikke tændes efter lagerafbrydelse eller fjernelse af snapshot. 
  • vCenter viser Virtual Machine disk consolidation is needed kvik.
  • Udførelse af en diskkonsolidering mislykkes og viser, at Another task is in progress.
Eksempel:
Skærmbillede af opgave, der viser fejlen

Cause

Dette problem opstår, når ikonet filename-ctk.vmdk Filen mangler.

Eksempel på fejllog:

Skærmbillede af VM-fejllog, der viser diskfejlen

Resolution

  1. Se opgavelisten for VM Indsamling af oplysninger om opgaver i VMware ESXi. Se Broadcom-artiklen 1013003 Indsamling af oplysninger om opgaver i VMware ESXi Dette hyperlink fører dig til et websted uden for Dell Technologies.
# vim-cmd vimsvc/task_list VMID 
  1. Kill Processen
# lsof | grep vm-name
# kill -9 process-id 
  1. Flyt alle CTK Filer i en midlertidig mappe
# mkdir temp
# mv *-ctk.vmdk 
  1. Kommenter ændringen, sporing fillinje i alle .vmdk, til stede i .vmx
# less .vmx | grep .vmdk 
# vi .vmdk
# :wq! 

 

Bemærk: Indsæt # for at kommentere linjen med CTK som nedenfor.

Skærmbillede af redigering af VMX-fil
 

  1. Opret en kopi af vmx fil, og rediger den derefter for at ændre den fra SAND til FALSK
# cp vm-name.vmx vm-name.vmx.bck
# vi vm-name.vmx
scsix:x.ctkEnabled = "TRUE" ----> scsix:x.ctkEnabled = "False" 
  1. Gem filen, og genindlæs vmx fil
# vim-cmd vmsvc/reload VMID 
  1. Du bør nu kunne tænde for VM'en. Konsolideringen er i gang.

Affected Products

VMware ESXi 6.x, VMware ESXi 7.x, VMware ESXi 8.x

Products

Poweredge C4140, PowerEdge C6420, PowerEdge C6520, PowerEdge C6525, PowerEdge C6615, PowerEdge C6620, PowerEdge FC640, PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge MX5016s, PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c , PowerEdge MX840C, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640 ...
Article Properties
Article Number: 000209549
Article Type: Solution
Last Modified: 17 Nov 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.