VMware: Impossibile accendere la macchina virtuale a causa di un problema di snapshot di consolidamento disco
Summary: Questo articolo spiega come risolvere una situazione in cui una macchina virtuale (VM) non si accende a causa di problemi con il consolidamento di un disco o una snapshot.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
- La macchina virtuale non si è accesa dopo un'interruzione dell'alimentazione dello storage o la rimozione di istantanee.
- vCenter mostra
Virtual Machine disk consolidation is neededvigile. - L'esecuzione di un consolidamento disco ha esito negativo e mostra che
Another task is in progress.
Esempio:
Cause
Questo problema si verifica quando il filename-ctk.vmdk File mancante.
Esempio di registro degli errori:

Resolution
- Controllare l'elenco delle attività per la macchina virtuale Raccolta di informazioni sulle attività in VMware ESXi. Consultare l'articolo Broadcom 1013003 Raccolta di informazioni sulle attività in VMware ESXi
# vim-cmd vimsvc/task_list VMID
KillIl processo
# lsof | grep vm-name # kill -9 process-id
- Sposta tutti i
CTKFile in una cartella temporanea
# mkdir temp # mv *-ctk.vmdk
- Commentare la modifica, tracciando la riga del file in tutte le
.vmdk, presente in.vmx
# less .vmx | grep .vmdk # vi .vmdk # :wq!
Nota: Inserire # per commentare la riga con
CTK come di seguito.

- Creare una copia di
vmxfile, quindi modificarlo in modo che cambi da TRUE a FALSE
# cp vm-name.vmx vm-name.vmx.bck # vi vm-name.vmx scsix:x.ctkEnabled = "TRUE" ----> scsix:x.ctkEnabled = "False"
- Salvare il file e ricaricare il file
vmxfile
# vim-cmd vmsvc/reload VMID
Consultare l'articolo VMware 2009244 ERRORE: "Impossibile aprire/creare file di rilevamento delle modifiche" all'accensione della macchina virtuale
- A questo punto dovrebbe essere possibile accendere correttamente la VM. Il consolidamento è in corso.
Affected Products
VMware ESXi 6.x, VMware ESXi 7.x, VMware ESXi 8.xProducts
Poweredge C4140, PowerEdge C6420, PowerEdge C6520, PowerEdge C6525, PowerEdge C6615, PowerEdge C6620, PowerEdge FC640, PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge MX5016s, PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c
, PowerEdge MX840C, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640
...
Article Properties
Article Number: 000209549
Article Type: Solution
Last Modified: 17 Nov 2025
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.