Dell Unity: limitazioni di SupportAssist per Unity OE 5.3

Summary: Questo articolo illustra le limitazioni di SupportAssist in Unity OE versione 5.3.

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Symptoms

SupportAssist (ESE) è integrato nella versione Unity v5.3 per sostituire Secure Remote Services per i sistemi Unity fisici a partire da Unity v5.3.
Gli scenari e i sintomi sono illustrati nella sezione relativa alla risoluzione di questo articolo.

Cause

Queste limitazioni possono verificarsi a causa di condizioni in Unity, SupportAssist o Secure Connect Gateway (SCG).

Resolution

Limitazione n. 1 La configurazione aggiornata del proxy non ha effetto per l'accesso remoto di SupportAssist.
Condizione in cui si verifica la limitazione
  1. Unity non dispone di connessione di rete a Dell Support Zone (esrs3-core.emc.com), ma solo tramite proxy.
  2. Connessione diretta in entrata o in uscita e opzione "Use Global Proxy server" selezionata in SupportAssist.
  3. Alcune impostazioni del server proxy, come l'indirizzo IP, la porta, il nome utente o la password, devono essere aggiornate.
Impatto sull'utente Il Supporto Dell non è in grado di connettersi al sistema Unity in remoto dopo la modifica delle impostazioni proxy.
Soluzione alternativa  Dopo aver modificato le impostazioni proxy:
1. Disabilitare e abilitare SupportAssist. 
OPPURE
2. Accedere tramite SSH a Unity ed eseguire manualmente "svc_supportassist r" per riavviare il servizio SupportAssist.
 
 
Limitazione n. 2 Dopo l'aggiornamento del codice Unity OE alla versione 5.3, in determinate situazioni potrebbe essere visualizzato un avviso. Questo avviso indica che Secure Remote Services non è riuscito a convertirsi in SupportAssist. Questo determina l'interruzione della connessione a Secure Remote Services.
Condizione in cui si verifica la limitazione Secure Remote Services integrato con il server proxy è stato configurato nella versione 5.2 o precedente. Unity non dispone di connessione di rete a Dell Support Zone (esrs3-core.emc.com), ma solo tramite proxy. Il codice Unity OE è stato aggiornato alla versione 5.3.
Impatto sull'utente Una connessione precedente viene persa e SupportAssist non viene inizializzato.
È presente un avviso post-aggiornamento in Unisphere: 14:38004b Migration from Integrated Secure Remote Services to SupportAssist failed. Configure SupportAssist manually.
Soluzione alternativa  Una volta completato l'aggiornamento di OE, inizializzare e configurare manualmente SupportAssist con chiave di accesso e PIN.
 
 
Limitazione n. 3 SupportAssist non supporta Policy Manager in modalità "Connect Directly".
Condizione in cui si verifica la limitazione Aggiornamento di Unity OE codice 5.2 o versioni precedenti alla versione 5.3, quando Policy Manager è configurato con Integrated Secure Remote Services in Unity 5.2 o versioni precedenti.
Impatto sull'utente
  • Dopo l'aggiornamento alla versione 5.3, le impostazioni di Policy Manager vengono perse e Policy Manager non gestisce più la comunicazione di rete tra Unity e Dell Support Zone.
  • Avviso post-aggiornamento: 14:38004d Policy manager is not supported by SupportAssist. Previous Policy manager (%2) has been removed during migration from Secure Remote Services.
Soluzione alternativa  Per continuare a utilizzare Policy Manager, selezionare la modalità "Connect through a gateway" in SupportAssist e configurare SCG. Quindi, configurare Policy Manager in SCG.
 
 
Limitazione n. 4 SupportAssist non supporta il server proxy di tipo SOCKS.
Condizione in cui si verifica la limitazione Secure Remote Services integrato viene abilitato con il server proxy di tipo SOCKS prima dell'aggiornamento.
(OPPURE) Il proxy SOCKS è configurato e l'opzione Use Global Proxy Settings è selezionata in 5.3.
Impatto sull'utente Gli utenti visualizzano un errore di controllo integrità pre-aggiornamento che blocca l'aggiornamento.
(OPPURE) Viene visualizzato un errore e SupportAssist non può essere abilitato sulla versione 5.3.
Soluzione alternativa  Utilizzare un proxy di tipo HTTP.
 
 
Limitazione n. 5 L'istanza centralizzata di Secure Remote Services (5.2 e versioni precedenti) supporta il gateway Secure Remote Services (3.x), il gateway SAE (4.x) o Secure Connect Gateway (5.z).
SupportAssist (5.3) supporta solo Secure Connect Gateway 5.12.00.10 e versioni successive.
Condizione in cui si verifica la limitazione Il gateway Secure Remote Services (3.x), SAE (4.y) o SCG (precedente a 5.12) è stato utilizzato nell'istanza centralizzata di Secure Remote Services prima dell'aggiornamento.
Impatto sull'utente Gli utenti visualizzano un errore di controllo integrità pre-aggiornamento che blocca l'aggiornamento di Unity OE.
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Soluzione alternativa  Eseguire l'aggiornamento a SCG 5.12 o versione successiva prima di avviare l'aggiornamento di Unity.
 
 
Limitazione n. 6 L'aggiornamento della chiave GEN 3 alla chiave universale GEN 4 non riesce quando è presente una chiave GEN 4 in Dell Support Zone.
Condizione in cui si verifica la limitazione Un sistema ha già abilitato SupportAssist durante l'esecuzione di OE 5.3 o versione successiva, quindi viene reinizializzato a una versione precedente alla 5.3. ESRS viene configurato su di esso e quindi viene aggiornato nuovamente alla versione 5.3.
Impatto sull'utente
  1. SupportAssist non viene inizializzato automaticamente durante l'aggiornamento alla versione 5.3. La connessione Secure Remote Services non viene convertita automaticamente in connessione SupportAssist.
  2. Avviso post-aggiornamento: 14:38004b Migration from Integrated Secure Remote Services to SupportAssist failed. Configure SupportAssist manually.
Soluzione alternativa  Contattare il Supporto Dell.
 
 
Limitazione n. 7 Gli utenti non possono più passare alla modalità "Connect through a gateway" quando "Connect directly" non funziona a causa di uno stato non valido del container SupportAssist.
Condizione in cui si verifica la limitazione
  1. È stata configurata la modalità "Connect directly"
  2. Il container SupportAssist passa a uno stato non valido e viene generato un avviso: 14:380057(SupportAssist service has stopped working. Repair it using the svc_supportassist service command.)
Impatto sull'utente Impossibile utilizzare la modalità "Connect through a gateway" come alternativa.
Soluzione alternativa  Correggere il container SupportAssist che si trova in uno stato non valido eseguendo "svc_supportassist c" e quindi abilitare nuovamente SupportAssist.
 
 
Limitazione n. 8 SupportAssist non segnala alcun errore quando si sostituisce un'istanza di SCG con un'altra che presenta un problema.
Condizione in cui si verifica la limitazione
  1. SupportAssist è abilitato in modalità "Connect through a gateway".
  2. Modifica dell'indirizzo del gateway in un altro SCG che non è in grado di connettersi al server Dell Support Zone.
Impatto sull'utente Viene visualizzata una falsa indicazione di esito positivo quando si modifica l'indirizzo SCG nella configurazione di SupportAssist.
Soluzione alternativa  Dopo aver aggiornato l'indirizzo SCG in una configurazione di SupportAssist, accedere manualmente all'interfaccia utente di SCG e verificare che la connessione sia valida.
 

Le limitazioni riportate di seguito sono presenti anche nella configurazione di Secure Remote Services (codice Unity OE 5.2 e versioni precedenti).
 
Limitazione n. 9 SupportAssist non supporta IPv6.
Condizione in cui si verifica la limitazione 1. La porta di gestione Unity è configurata solo con un indirizzo IPv6.
Oppure
2. Durante la configurazione di SupportAssist, viene specificato solo l'indirizzo IPv6 come indirizzo SCG.
Impatto sull'utente
  • Per la condizione 1, SupportAssist non può essere abilitato in alcuna modalità, "Connect Directly" o "Connect through a gateway".
  • Per la condizione 2, SupportAssist non può essere abilitato quando IPv6 viene utilizzato per SCG.
  • Questa limitazione è presente anche nelle istanze di Secure Remote Services centralizzate e integrate.
Soluzione alternativa  Per la condizione 1, configurare sia un indirizzo IPv4 che un indirizzo IPv6 per la porta di gestione Unity.
Per la condizione 2, utilizzare l'indirizzo IPv4 o il nome di dominio completo di SCG.
 
 
Limitazione n. 10 Le modifiche alle impostazioni in SCG non vengono sincronizzate con SupportAssist.
Condizione in cui si verifica la limitazione Un utente modifica l'impostazione di accesso remoto nell'interfaccia utente di SCG anziché nell'interfaccia utente di Unity Unisphere.
Impatto sull'utente
  • Unity può segnalare uno stato di accesso remoto errato se è stata apportata una modifica all'interno di SCG.
  • Il problema è presente anche nelle istanze centralizzate di Secure Remote Services.
Soluzione alternativa  Non gestire modifiche nell'interfaccia utente di SCG, utilizzare solo l'interfaccia utente di Unity Unisphere o UEMCL.
 
 
Limitazione n. 11 L'istanza di SCG reinstallata non ripristina la connessione precedente.
Condizione in cui si verifica la limitazione Deployment di un nuovo dispositivo SCG (con lo stesso indirizzo IP) per sostituire quello utilizzato in una configurazione esistente che presenta problemi.
Impatto sull'utente La connessione è interrotta e sia l'accesso remoto che RSC smettono di funzionare.
Questo problema è presente anche nelle istanze centralizzate di Secure Remote Services.
Soluzione alternativa  Abilitare nuovamente SupportAssist con lo stesso indirizzo SCG.
 
 
Limitazione n. 12 SupportAssist non segnala alcun errore quando la connessione SCG a Dell Support Zone è interrotta.
Condizione in cui si verifica la limitazione SupportAssist viene abilitato utilizzando la modalità "Connect through a gateway" (Secure Connect Gateway). La connessione è stata stabilita correttamente. La connessione tra Secure Connect Gateway e Dell Support Zone viene interrotta o il server Dell Support Zone è inattivo.
Impatto sull'utente
  • L'utente non è a conoscenza del fatto che la connessione Secure Connect Gateway (SCG) è già interrotta.
  • Impossibile inviare dati call-home o CloudIQ a Dell.
  • L'accesso remoto non funziona.
Soluzione alternativa 
  • Configurare le notifiche e-mail su SCG per ricevere notifiche sullo stato di integrità generale. Riparare la connessione interrotta quando si riceve una notifica. Per configurare le notifiche e-mail, consultare la guida utente di Secure Connect Gateway.
  • Nell'interfaccia utente di SCG, verificare manualmente lo stato della connessione di rete tra SCG e i server Dell Support Zone. Consultare la guida utente di Secure Connect Gateway.
 
 
Limitazione n. 13 La sessione remota di CLIviaSSH o Unisphere attiva viene mantenuta attiva anche dopo che l'utente disabilita la connettività in entrata in SupportAssist.
Condizione in cui si verifica la limitazione L'utente disabilita la connettività in entrata per l'opzione di accesso remoto quando è presente una sessione attiva.
Oppure
L'utente disabilita completamente la connessione SupportAssist quando è presente una sessione attiva.
Impatto sull'utente Il Supporto Dell potrebbe utilizzare l'accesso remoto attivo al sistema Unity e modificare Unity.
Soluzione alternativa  L'utente non può disabilitare la sessione in entrata attiva.
Nota:
1. La sessione attiva scade se rimane inattiva per oltre 30 minuti.
2. Una volta disabilitata la connettività in entrata, non è possibile avviare una nuova sessione di accesso remoto.
 
 
Limitazione n. 14 Il supporto può comunque stabilire la sessione remota dopo che un utente esegue la pulizia di SupportAssist in determinate condizioni.
Condizione in cui si verifica la limitazione
  • L'utente avvia un'operazione di pulizia in Unity perché il servizio SupportAssist non è in uno stato valido (alert14:380057) o si verificano problemi con la disabilitazione normale della connessione.
  • La richiesta di disabilitazione di SupportAssist durante la pulizia non riesce.
Impatto sull'utente
  • Il Supporto Dell potrebbe comunque accedere in remoto al sistema Unity e modificare Unity.
  • Questo problema si verifica in Unity 5.2 e versioni precedenti.
Soluzione alternativa  Contattare il Supporto Dell quando viene visualizzato il messaggio di errore riportato di seguito dopo aver eseguito uno script di pulizia.
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Affected Products

Dell EMC Unity Family |Dell EMC Unity All Flash

Products

Dell EMC Unity
Article Properties
Article Number: 000210339
Article Type: Solution
Last Modified: 18 Jun 2024
Version:  4
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