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PowerProtect: VM backup fail indicating a DPD Sync is in progress

Summary: A few virtual machine (VM) Asset backups started to fail after they were completing successfully. The failure details indicate the vCenter task fails with a TSDM error indicating "DPD Sync in progress." ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The PowerProtect Data Manager is used to protect the vSphere environment with the Transparent Snapshot Data Mover (TSDM) solution. A few VM Asset backups started to fail, when they were completing successfully in the past. The failure details indicate the vCenter task fails with a TSDM error indicating "DPD Sync in progress." The ABV0016 and ABV0006 details show:

details dialogue box of errors of failed backup of host
ABV0016: VM Direct engine 'localhost' is unable to back up the virtual machine 'my-vm-name' on vCenter 'my-vcernter-name' because of a vCenter API issue.

The VM Direct engine cannot complete the backup of this virtual machine because of a vCenter API operation did not complete successfully.

To troubleshoot this issue: 1) Verify that the vCenter can be reached. 2) If the vCenter is busy, wait for some activities to complete and then retry the operation. 3) Verify that the virtual machine exists on the vCenter.

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Unable to cleanup from earlier backup attempt.  Unable to cleanup session 'Backup:6755cb99-3de5-4731-8b6f-6c64bb809f0b' from virtual machine 'my-vm-name' (MORef = 'vm-241').  Unable to cancel TSDM / LWD snapshot.  The vCenter task for 'Cancel SDM Snapshot' completed with state 'error':  DPD Sync in progress.
ABV0006: VM Direct engine 'localhost' is unable to back up the virtual machine 'my-vm-name' on vCenter 'my-vcernter-name' because of a vCenter API issue.

The VM Direct engine cannot complete the backup of this virtual machine because of a vCenter API operation did not complete successfully.

To troubleshoot this issue: 1) Verify that the vCenter can be reached. 2) If the vCenter is busy, wait for some activities to complete and then retry the operation. 3) Verify that the virtual machine exists on the vCenter.

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vCenter task 'task-943698' failed:  VimFault: 'dp.vpx.fault.SnapshotInProgress.summary': DPD Snapshot in progress

The Backup session may show the following status outputs:
...
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]   },
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]   "Status": {
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]     "State": "Failure",
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]     "Description": "Backup is unsuccessful:  Unable to cleanup from earlier backup attempt.  Unable to cleanup session 'Backup:6755cb99-3de5-4731-8b6f-6c64bb809f0b' from virtual machine 'vm-vm-name' (MORef = 'vm-241').  Unable to cancel TSDM / LWD snapshot.  The vCenter task for 'Cancel SDM Snapshot' completed with state 'error':  DPD Sync in progress",
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]     "Progress": 0,
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]     "Error": {
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]       "Text": "Unable to cleanup from earlier backup attempt.  Unable to cleanup session 'Backup:6755cb99-3de5-4731-8b6f-6c64bb809f0b' from virtual machine 'vm-vm-name' (MORef = 'vm-241').  Unable to cancel TSDM / LWD snapshot.  The vCenter task for 'Cancel SDM Snapshot' completed with state 'error':  DPD Sync in progress",
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]       "Code": 0,
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]       "Classifications": [],
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]       "Retryable": false,
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]       "Remedy": null
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]     },
...
...
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]   },
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]   "Status": {
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]     "State": "Failure",
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]     "Description": "Backup is unsuccessful:  vCenter task 'task-943698' failed:  VimFault: 'dp.vpx.fault.SnapshotInProgress.summary': DPD Snapshot in progress, TSDM snapshot UUID = '52031978-18dd-444a-37fd-9c070de84cc5'",
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]     "Progress": 0,
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]     "Error": {
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]       "Text": "vCenter task 'task-943698' failed:  VimFault: 'dp.vpx.fault.SnapshotInProgress.summary': DPD Snapshot in progress, TSDM snapshot UUID = '52031978-18dd-444a-37fd-9c070de84cc5'",
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]       "Code": 0,
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]       "Classifications": [],
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]       "Retryable": false,
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]       "Remedy": null
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]     },
...
 

Cause

The affected VM has an orphaned vSphere Snapshot Data Mover (SDM) task that the PowerProtect Data Manager TSDM backup workflow cannot cancel. The reason for the orphaned task remains unidentified.

Resolution

The SDM feature should be disabled and enabled on the affected VM to clear the orphan vSphere SDM snapshot task. Here are some of the available methods to disable and enabled the SDM on the affected VM.

Workaround 1

Change the affected VM asset protection mechanism.

  1. Open a browser session to PowerProtect Data Manager and authenticate with an admin account.
  2. Browse to "Infrastructure > Assets > Virtual Machines."
  3. Select the affected virtual machine.
  4. Select the dropdown "More Actions > Protection Mechanism > Migrate to VADP."
  5. The vSphere Web Client shows a task for the virtual machine to disable the Lightweight Delta (LWD) filter.
  6. Select the dropdown "More Actions > Protection Mechanism > Migrate to Transparent Snapshots."
  7. The vSphere Web Client shows a task for the virtual machine to enable the LWD filter.
  8. Run a backup or monitor the scheduled backup execution.

Workaround 2

Remove and add the affected VM from the Protection Policy.

  1. Open a browser session to PowerProtect Data Manager and authenticate with an admin account.
  2. Browse to "Infrastructure > Assets > Virtual Machines."
  3. Select the affected virtual machine.
  4. Select the dropdown "More Actions > Remove from Policy."
  5. The vSphere Web Client shows a task for the virtual machine to disable the Lightweight Delta (LWD) filter.
  6. Select the dropdown "More Actions > Add to Policy" and follow the wizard to add to the Protection Policy.
  7. The vSphere Web Client shows a task for the virtual machine to enable the LWD filter.
  8. Run a backup or monitor the scheduled backup execution.

Workaround 3

The PowerProtect Data Manager vmconfig command-line utility can be used to change the SDM feature setting for the affected VM.

  • Log in to the PowerProtect Data Manager Appliance using SSH with the admin account:
     ssh admin@my-ppdm-name
  • Change to the root user:
    sudo su 
  • Load the environment variables:
    source /opt/emc/vproxy/unit/vproxy.env
  • Change to the vproxy bin directory:
    cd /opt/emc/vproxy/bin/
  • Construct the vmconfig command by replacing the information in the brackets:
    • Check the VM status:
      ./vmconfig -v <vcenter-ip-fqdn> -u '<vcenter-user-name>' -p '<vcenter-user-pwd>' -l dns -k <VM DNS name> -c info
    • Disable SDM on the VM:
      ./vmconfig -v <vcenter-ip-fqdn> -u '<vcenter-user-name>' -p '<vcenter-user-pwd>' -l dns -k <VM DNS name> -c disable-sdm
    • Enable SDM on the VM:
      ./vmconfig -v <vcenter-ip-fqdn> -u '<vcenter-user-name>' -p '<vcenter-user-pwd>' -l dns -k <VM DNS name> -c enable-sdm
  • Run a PowerProtect Data Manager TSDM backup to confirm the issue is resolved.
Article Properties
Article Number: 000210949
Article Type: Solution
Last Modified: 24 Oct 2024
Version:  4
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