CloudLink: CloudLink Mail notification does not work "Sending the email to the following server failed...."

Summary: CloudLink Mail notification does not work "Sending the email to the following server failed...."

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Mail notification test shows that "Sending the email to the following server failed: XXX.XXX.XXX.XXX:25"

cloudlink-errors.log:
2023-02-20 04:39:17,377 ERROR [/cloudlink/rest/email/test (qtp1485955886-192095)] c.a.g.e.s.m.EmailNotificationServiceBean.sendTestEmail(…) (EmailNotificationServiceBean.java:179) Failed to send test email: Sending the email to the following server failed: xxxxx.xxxxx.com.xxx:25
org.apache.commons.mail.EmailException: Sending the email to the following server failed: xxxxx.xxxxx.com.xxx:25
    at org.apache.commons.mail.Email.sendMimeMessage(Email.java:1469)
    at org.apache.commons.mail.Email.send(Email.java:1496)
...
...
...
Caused by: javax.mail.MessagingException: Could not connect to SMTP host: mailout.optus.com.xxxxx.xxxxx.com.xxx, port: 25, response: 554
    at com.sun.mail.smtp.SMTPTransport.openServer(SMTPTransport.java:2106)
    at com.sun.mail.smtp.SMTPTransport.protocolConnect(SMTPTransport.java:712)
    at javax.mail.Service.connect(Service.java:295)
    at javax.mail.Service.connect(Service.java:176)
    at javax.mail.Service.connect(Service.java:125)
    at javax.mail.Transport.send0(Transport.java:194)
    at javax.mail.Transport.send(Transport.java:124)
    at org.apache.commons.mail.Email.sendMimeMessage(Email.java:1459)
    ... 95 common frames omitted

Cause

The HTTP response code 554 means that the receiving server sees something in the From or To Headers of the message, that it does not like.
There are several causes for this. An invalid mail title, or the sender has been blocked or is not in the allowlist for the receiving mail server.
In this case, the allowlist setting for the mail server was only accepting mail requests from the IPs on the allowlist.

Resolution

To resolve this issue, add the Cloudlink nodes into the allowlist for that mail server.

Affected Products

CloudLink SecureVM, CloudLink
Article Properties
Article Number: 000211326
Article Type: Solution
Last Modified: 31 Mar 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.