Avamar: Unable to log in to the Avamar User Interface or Java Administrator as username "MCUser"

Summary: The following are steps to resolve the Avamar User Interface (AUI) access.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Unable to log in to the Avamar Administrator, an error appears with the message:

0 ERROR! Exit code 69: Authentication failure"

 

And, when trying to access the AUI Avamar site, the following error appears.

User Authentication Failed

 

Cause

It is possible that the MCUser password is failing authentication. It is necessary to reset the root and MCUser passwords.

 

Resolution

To investigate the issue, do the following:

  1. Run the avmgr logn --id=MCUser --ap=<password> command.

    Possible output:

0  ERROR!  Exit code 69: Authentication failure  (Invalid password?  User disabled?) 
     2023/01/16-18:13:02.49198 [avmgr]  ERROR: <0001> uplinkcallbase::send   Could not send message to dispatcher

 

  1. Check that all services are up with:

dpnctl status

 

  1. Check that the dispatcher is enabled with:

status.dpn

 

  1. Stop any active backup or replication jobs since MCS is restarted.

  2. Prepare the current root and MCUser passwords.

  3. Run the change-passwords command as root user.

    • Prompts are going to show up.
    • SSL message type "no"
    • Change OS (login) passwords? Type "no."
    • Generate new SSH keys? Type "no."
    • Change Avamar Server passwords? Type "yes."
    • Change Avamar Server password for "MCUser"? Type "yes."
    • Enter the MCUser password twice.
    • Change the Avamar Server password for "root"? Type "yes."
    • Enter the root password twice.
    • Change Avamar Server password for "repluser"? Type "no."
    • Change the viewuser password? Type "no."
  4. Once you complete the prompts, it asks if you to restart the MCS database, type "yes."

  5. Wait until it completes and check that all services are up with the dpnctl status command

  6. Try login back to the Avamar Administrator Java or AUI site as MCUser.

 

If the issue persists, contact Dell support.

 

Affected Products

Avamar Data Store
Article Properties
Article Number: 000211461
Article Type: Solution
Last Modified: 07 Feb 2024
Version:  2
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