Connectrix Cisco MDS: MDS passwords strings should allow question mark (?) in clear text input.
Summary: An NX-OS password with a "?" Character cannot be entered at the CLI or using a script such as the NX-OS CLI on all MDS Platforms.
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Symptoms
An NX-OS password with a "?"" Character cannot be entered at the CLI or using a script as the NX-OS CLI parser interprets it as the inline help command.
Example:
switch(config)# username san-admin password 123?
WORD Password for the user (clear text) (Max Size 127)
WORD Password for the user (clear text) (Max Size 64)
switch(config)# tacacs-server host x.x.x.x key 7 LP,K?
WORD TACACS+ shared secret(encrypted) (Max Size 63)
Cause
The issue is witnessed when configuring both Normal and AAA User passwords on MDS switches.
Resolution
Workaround:
- Prepend a 'ctrl-v' key combination before each "?" Character.
Further Problem Description:
- This issue may prevent using the same password on products from multiple vendors as the "?" Character is accepted in passwords by other vendors.
Cisco MDS 9000 NX-OS and SAN-OS Software known affected - 8.3(1)
Fix: Known Fixed Releases: 8.4(2) and later
Note:
- Suggested not to use Question Mark (?) in the normal user or AAA user passwords.
Additional Information
Best Practice refer "Cisco Nexus 9000 Series NX-OS Security Configuration Guide"
For Username:
- Usernames must begin with an alphanumeric character and can contain only these special characters: ( + = . _ \ -).
- The # and ! Symbols are not supported. If the username contains characters that are not allowed, the specified user is unable to log in.
For Password:
- Special characters, such as the dollar sign ($) or the percent sign (%), can be used in Cisco Nexus device passwords.
Affected Products
Connectrix MDS-SeriesArticle Properties
Article Number: 000212190
Article Type: Solution
Last Modified: 14 Apr 2025
Version: 3
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