Dell Unity: Järjestelmänvalvojan ja palvelun salasanan nollaaminen painamalla NMI-painiketta ei ehkä toimi
Summary: Jos sekä STIG että /user/account/settings ovat käytössä, järjestelmänvalvojan ja palvelun salasanan vaihtaminen ei välttämättä toimi tietokanta-artikkelin 22355 mukaisesti (Dellin korjattavissa). ...
Symptoms
Käyttäjä ei välttämättä tiedä järjestelmänvalvojan tai palvelun salasanoja, eikä niiden nollaaminen painamalla NMI-painiketta toimi yhdellä niistä.
Dellin tietämyskannan artikkeli 22355, Dell Unity: Järjestelmänvalvojan tai palvelun salasanan vaihtaminen, lukituksen avaaminen tai nollaaminen (käyttäjän korjattavissa).
Havainnot:
- Käyttäjä on painanut NMI-painiketta sekä SPA: ssa että SPB: ssä, mutta ei silti voi kirjautua sisään oletusjärjestelmänvalvojan tai palvelun salasanoilla.
- Joko järjestelmänvalvojan tai palvelun salasanan havaitaan nollautuvan NMI-nollauksen yhteydessä, mutta ei molempia.
- Jos STIG-banneria ei ole poistettu käytöstä, kun järjestelmänvalvojan salasana syötetään Unispheren kirjautumisnäytössä, ensimmäinen STIG-banneri näytetään uudelleen. Banneri on poistettava käytöstä seuraavissa toiminnoissa:
svc_banner -dnähdäksesi järjestelmänvalvojan salasanan palautuksen epäonnistuminen kirjautuminen Unisphereen. Banneria ei saa poistaa käytöstä, ellei se ole välttämätöntä, koska se voidaan ratkaista suunnitteluavulla. - Kun STIG-banneri on poistettu käytöstä, yritys kirjautua Unisphereen järjestelmänvalvojan salasanalla NMI-nollauksesta tuottaa edelleen virheen: "Antamasi käyttäjätunnus tai salasana on virheellinen. Yritä uudelleen."
- Sama virhe näkyy myös käytettäessä sshclin komentoa, joka edellyttää järjestelmänvalvojan salasanaa.
Cause
Kun käyttäjä/tili/asetukset on otettu käyttöön, salasanan vähimmäiskoko on oletusarvoisesti 15. Se voi olla suurempi luku, jos käyttäjä on koskaan muuttanut sitä. Nykyinen NMI-nollausmenettely käyttää väärennettyä salasanaa ennen oletussalasanan palauttamista. Tämä väärennetty salasana ei ole tarpeeksi pitkä täyttämään STIG: n "Password Minimum Size" -vaatimusta. Tässä tapauksessa NMI-nollaus epäonnistuu.
Resolution
NMI-ongelman ratkaiseminen tapahtuu eri tavalla riippuen siitä, onko palvelun salasana vai järjestelmänvalvojan salasana nollattava vai ei.
Käyttötapaus #1: Palvelun salasanan NMI-nollaus ei toimi.
Anna NMI-prosessin toimia seuraavasti, jos palvelun käyttäjän salasanan nollaus ei toimi:
- Poista ensisijaisen SP:n /user/account/settings käytöstä ennen NMI-painikkeen painamista. Tämä voi toimia järjestelmänvalvojan roolissa tai suojauksen järjestelmänvalvojan roolissa.
uemcli -no -d <Unity_IP> -u admin -p <password> /user/account/settings set -enabled no
Tai
uemcli -no -d <Unity_IP> -u <security administrator role user> -p <password> /user/account/settings set -enabled no
- Paina ensisijaisen SP: n NMI-painiketta nollataksesi sekä järjestelmänvalvojan että palvelun käyttäjien salasanat.
STIG-vaatimuksia varten käyttäjän on asetettava "Salasanan vähimmäiskoko" -arvoksi haluamansa arvo hakemistossa /user/account/settings myöhemmin.
Käyttötapaus #2: Järjestelmänvalvojan salasanan NMI-nollaus ei toimi.
Päätöslauselman:
Dell lisää parannuksen tulevaan Unity OE -versioon. Parannuksen ansiosta NMI:n nollaus toimii palauttamalla salasanan vähimmäiskooksi 8. Tämä on oletusarvo, kun /user/account/settings ei ole käytössä. Katso lisätietoja tästä tietämyskannan artikkelista.
Workaround:
Jos käyttäjä unohtaa järjestelmänvalvojan salasanan eikä hänellä ole suojauksen järjestelmänvalvojan roolikäyttäjiä, ota yhteys Dellin tekniseen tukeen. Se tarkoittaa "mukautetun järjestelmänvalvojan salasanan palautustyökalun" pyytämistä salasanan vähimmäispituusvaatimuksen ja käytössä olevan OE-kooditason perusteella.
Ota yhteys Dellin tekniseen tukeen tai valtuutettuun palveluntarjoajaan ja mainitse tämän tietämyskannan artikkelin numero.
Additional Information
Jos ennen kirjautumista näkyvä STIG-oletusbanneri poistetaan käytöstä vianmäärityksen aikana, kun käytössä on svc_banner -d, banneri on lisättävä takaisin mukautetun bannerin avulla.
Siirry Dell Support Unity -tuotesivulle ja tutustu Hallinta-välilehdestä löytyvään asiakirjaan Service Commands Technical Notes .
/etc/motd sisältää yleensä kopion STIG-oletusbannerista. Sisältö voidaan kopioida en_US.txt tiedostoon, jota käytetään STIG-bannerisisällön lisäämiseen. STIG:lle on yleensä kaksi banneria riippuen siitä, onko kategoria 1 vai kategoria 2 STIG käytössä.