Error Message "This Boot Will Take Longer Than Usual, Please Wait" on Latitude Laptops
Summary: "This boot takes longer than usual, please wait…" error message on Latitude 9330, Latitude 9430, Dell Pro 13 Premium, and Latitude 9440 2-in-1.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
You may see the following error message display on-screen when booting the Latitude 9440 2-in-1:
"This boot takes longer than usual, please wait."

The message remains for a long duration, and the laptop power button cannot be used to force the laptop to turn off. However, the screen may stop responding and it looks that there is no way to turn it off.
Affected Platforms:
- Latitude 9330
- Latitude 9430
- Latitude 9440 2-in-1
- Dell Pro 13 Premium
Cause
The error may occur if both the AC adapter and the battery are disconnected from the laptop and the Complementary metal-oxide-semiconductor (CMOS) has not been cleared. Upon the first boot, an Intel Management Engine (ME) reinitialization occurs which triggers the boot message if the CMOS has not been cleared.
Resolution
Update the BIOS version 1.1.6 or the latest version for Latitude 9440 2-in-1.
Update the BIOS version to 1.15.0 or the latest version for Latitude 9430.
Update the BIOS version to1.12.0 or the latest version for Latitude 9330 and Dell Pro 13 Premium.
For information about updating the BIOS, see: BIOS Update Guide
If the error persists, contact Dell Technical Support for the resolution.
Affected Products
Dell Pro 13 Premium PA13250, Latitude 9330, Latitude 9430, Latitude 9440 2-in-1Article Properties
Article Number: 000212463
Article Type: Solution
Last Modified: 13 Nov 2025
Version: 16
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.