PowerStore. Непредусмотренная перезагрузка узла из-за клапана порта FC

Summary: Во время обработки уведомления об изменении зарегистрированного состояния (RSCN) может произойти утечка памяти в драйвере FC узла PowerStore. В результате память, необходимая для возврата списка имен портов и узлов, зонированных для системы, может быть не освобождена должным образом. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Симптомы могут включать:

  • Сбой узла из-за неожиданной перезагрузки
  • Критическая ошибка ядра (нехватка памяти) OOM из-за отключения порта FC
  • Затронутому HBA-адаптеру хоста не удается обеспечить стабильное подключение
  • Потеря доступа к данным на стороне хоста

 

Cause

При изменении состояния устройства (входа/выхода) в фабрике SAN коммутатор отправляет уведомления RSCN всем подключенным устройствам.
Драйвер PowerStore FC отправляет команды коммутатору для запроса идентификаторов WWN, которые находятся в зоне PowerStore.
Память выделена для такого запроса, но может быть не освобождена должным образом.

 

Resolution

Проблема, устраненная в PowerStoreOS версии 3.5.x.x

Работоспособность узла автоматически восстановится после неожиданной перезагрузки.

 

Additional Information

Необходимо определить неисправный WWN и исправить его или отключить.
Просмотрите журналы коммутатора и хоста, чтобы определить причину проблем.
Возможные причины ненадежности портов: неплотный или грязный кабель FC, неисправный порт коммутатора, неисправный SFP, HBA-адаптер хоста или драйвер/микропрограмма HBA-адаптера хоста.
Необходимо проверить совместимость драйверов/микропрограмм HBA-адаптера хоста.

Примеры колебаний портов, когда состояние порта изменено с «онлайн» на «автономно»:

Пример хлопанья порта 2 на коммутаторе Brocade:

fabriclog --show       :
Time Stamp      Input and *Action                           S, P   Sn,Pn  Port  Xid
===================================================================================
Switch 0; Sat Mar 19 10:02:31 2022 GMT (GMT+0:00)
10:02:31.817858 SCN Port Offline;rsn=0x4,g=0x4fd58          D2,P0  D2,P0  2     NA   
10:02:31.817865 *Removing all nodes from port               D2,P0  D2,P0  2     NA   
10:02:31.831807 SCN LR_PORT(0);g=0x4fd58                    D2,P0  D2,P0  2     NA   
10:02:31.840928 SCN Port Online; g=0x4fd58,isolated=0       D2,P0  D2,P1  2     NA   
10:02:31.841017 Port Elp engaged                            D2,P1  D2,P0  2     NA   
10:02:31.841034 *Removing all nodes from port               D2,P0  D2,P0  2     NA   
10:02:31.841093 SCN Port F_PORT                             D2,P1  D2,P0  2     NA 

Пример хлопанья порта fc1/22 коммутатора Cisco:

`show port-config internal all`
*************** Port Config Port Control Log ***************
----                            ------  -----------         -------
Time                            PortNo  Port Action         ErrCode
----                            ------  -----------         -------
Mar 19 12:27:53 2023  00986053  fc1/22  Enable              None
Mar 19 12:27:53 2023  00984797  fc1/22  Participating Mode  None
Mar 19 12:13:43 2023  00558421  fc1/22  Enable              None
Mar 19 12:13:43 2023  00557170  fc1/22  Participating Mode  None
Mar 19 12:02:21 2023  00738769  fc1/22  Enable              None
Mar 19 12:02:21 2023  00737461  fc1/22  Participating Mode  None
Mar 19 11:40:58 2023  00976928  fc1/22  Enable              None
Mar 19 11:40:58 2023  00975543  fc1/22  Participating Mode  None
Mar 19 11:39:01 2023  00195273  fc1/22  Enable              None
Mar 19 11:39:01 2023  00193893  fc1/22  Participating Mode  None
Mar 19 11:37:13 2023  00341497  fc1/22  Enable              None
Mar 19 11:37:13 2023  00340169  fc1/22  Participating Mode  None 

 

Affected Products

PowerStore
Article Properties
Article Number: 000212694
Article Type: Solution
Last Modified: 22 Nov 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.