NetWorker: nmc_config fails on a Linux server with "Unable to Contact Authentication Server on Host Networker_server_hostname and Port 9090"

Summary: This article deals with warning while configuring NMC on a networker server as "WARNING: Unable to contact authentication server on host Networker_server_hostname and port 9090" when the Linux server is configured with proxy hosts. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • The NetWorker Management Console (NMC) server is installed on an RHEL based Linux operating system.
  • When running the NMC configuration script (/opt/lgtonmc/bin/nmc_config), it fails to contact the authentication server on authc port 9090.
[root@networker_server_hostname /]# /opt/lgtonmc/bin/nmc_config
The embedded web server inside the NMC server must run as a non-root user.
Dell recommends that you specify a user that has limited privileges and file access permissions. Default user name used is 'nsrnmc'.
Do you want to create new(cn) certificate or use existing(ue) certificate [cn]?
Create new certificate for https configuration.
Specify the directory to use for the LGTOnmc database[/nsr/nmc/nmcdb]:
Do you want to migrate the NMC server data from a previous LGTOnmc 8.x.x release [n]?
Specify the host name of the Networker Authentication Service host [Networker_server_hostname]:
WARNING: Unable to contact authentication server on host Networker_Server_hostname and port 9090
Do you want to specify a different authentication server host or port [y]?

Cause

Proxy was enabled on the server.
 
  1. The error below is from /opt/lgtonmc/logs/install.log
129356:gstauthcfg: Unable to get supported versions from authentication server: Received HTTP code 403 from proxy after CONNECT
Server Message : Make sure that server is running
  1. The following command shows the proxies active:
[root@Networker_server_hostname /]# env |grep -i proxy
http_proxy=http://<proxy-server>:8080
https_proxy=http://<proxy-server>:8080

Resolution

NOTE: The below procedure must be performed by the Linux system admin.
  1. Make note of the proxies which are configured on the system:
[root@Networker_server_hostname /]# env | grep -i proxy
http_proxy=http://<proxy-server>:8080
https_proxy=http://<proxy-server>:8080
  1. If proxy entries are specified in /etc/profile comment them out and log off.
  2. Log in to the NetWorker server again and rerun the NMC configuration script: sudo /opt/lgtonmc/bin/nmc_config

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000216702
Article Type: Solution
Last Modified: 29 Nov 2023
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.