Dell ThinOS 9 voert een netwerkdiagnose uit na een mislukte verbindingspoging

Summary: In dit artikel wordt beschreven waarom Dell ThinOS een netwerkdiagnose uitvoerde en waarom deze mislukte.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Betreffende platforms:

  • OptiPlex 3000 Thin Client
  • Wyse 5070 Thin Client
  • Wyse 5470 mobile Thin Client
  • Wyse 5470 alles-in-één thin client
  • Wyse 3040 Thin Client
  • Latitude 3420
  • Latitude 3440
  • Latitude 5440
  • OptiPlex 5400 All-in-One
  • OptiPlex 7410 All-in-One

Betreffende besturingssystemen:

  • Dell ThinOS

Na een mislukte verbindingspoging kunnen ThinOS 9-klanten een beveiligingsprobleem melden wanneer ThinOS een diagnostische netwerkfunctie uitvoert die probeert verbinding te maken met een externe openbare server. Dezelfde situatie kan worden geactiveerd bij het gebruik van geïntegreerde diagnostische hulpprogramma's voor het netwerk van ThinOS (Probleemoplossing >voor netwerkdiagnose>).

Klanten hebben deze situatie gedetecteerd wanneer hun interne firewallsoftware clientcommunicatiepogingen rapporteert aan IP 47.100.193.85 of dell1.com wanneer een NTP-server niet bereikbaar is vanaf de thin client, of wanneer de klant een lokale diagnostische test voor het ThinOS-netwerk uitvoert.

Cause

Een hard gecodeerde URL-waarde die bedoeld is voor www.dell.com is per ongeluk gedefinieerd als www.dell1.com.

Opmerking: Hoewel er een verbinding met een externe openbare server tot stand is gebracht, zijn er geen gegevens naar de client geschreven die de beveiliging in gevaar kunnen brengen of het gedrag van de ThinOS-client kunnen veranderen.

Resolution

  • ThinOS 2306 is uitgebracht in juni 2023 en heeft dit probleem opgelost.
  • ThinOS 2308 staat gepland voor release in augustus 2023, updates hieronder:
    • Andere diagnostische logica van het netwerk in de code verwijderd; alleen de logica van de netwerkdiagnose behouden in Probleemoplossing waarbij de gebruiker de diagnose handmatig activeert.
    • Bij Probleemoplossing > voor netwerkdiagnose>
      • De webtoegangstest wordt ook verwijderd (waarvoor bijvoorbeeld een externe URL www.dell.com nodig was)
      • Hield de PING als DNS stappen oplossen, bericht toegevoegd dat de gebruiker op Doorgaan moet klikken
        • Voorheen moest de gebruiker op Diagnostics klikken
        • Nu moet de gebruiker op Diagnostics en Continue klikken
          Probleemoplossing: de gebruiker moet op Doorgaan klikken

Affected Products

Latitude 3420, Latitude 3440, Latitude 5440, OptiPlex 3000 Thin Client, OptiPlex 5400 All-In-One, OptiPlex All-In-One 7410, Wyse 3040 Thin Client, Wyse 5070 Thin Client, Wyse 5470 All-In-One, Wyse 5470, Dell ThinOS
Article Properties
Article Number: 000217192
Article Type: Solution
Last Modified: 24 Apr 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.