Systém Dell ThinOS 9 provede po neúspěšném pokusu o připojení diagnostiku sítě

Summary: Tento článek pojednává o tom, proč systém Dell ThinOS spustil síťovou diagnostiku a proč selhala.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Dotčené platformy:

  • Tenký klient OptiPlex 3000
  • Tenký klient Wyse 5070
  • Mobilní tenký klient Wyse 5470
  • Tenký klient Wyse 5470 All-in-One
  • Tenký klient Wyse 3040
  • Latitude 3420
  • Latitude 3440
  • Notebook Latitude 5440
  • OptiPlex 5400 All-in-One
  • OptiPlex 7410 All-in-One

Dotčené operační systémy:

  • Dell ThinOS

Po neúspěšném pokusu o připojení mohou zákazníci se systémem ThinOS 9 vznést problém se zabezpečením, když systém ThinOS provede funkci diagnostiky sítě, která se pokusí připojit k externímu veřejnému serveru. Ke stejnému stavu může dojít při použití integrovaných diagnostických nástrojů sítě v systému ThinOS (Odstraňování problémů > s diagnostikousítě>).

Zákazníci tento stav zjistili, když interní software brány firewall hlásí pokusy o komunikaci s klientem na adresu IP 47.100.193.85 nebo dell1.com, když server NTP není dostupný z tenkého klienta nebo když zákazník spustí místní diagnostický test sítě ThinOS.

Cause

Pevně zakódovaná hodnota adresy URL určená pro www.dell.com byla neúmyslně definována jako www.dell1.com.

Poznámka: Při připojení k externímu veřejnému serveru nebyla do klienta zapsána žádná data, která by ohrozila zabezpečení nebo změnila chování klienta se systémem ThinOS.

Resolution

  • Systém ThinOS 2306 byl vydán v červnu 2023 a tento problém byl vyřešen.
  • Vydání systému ThinOS 2308 je naplánováno na srpen 2023, aktualizace jsou uvedeny níže:
    • Odebrali jsme další logiku diagnostiky sítě v kódu. zachoval pouze logiku diagnostiky sítě v řešení potíží , kde uživatel ručně spustí diagnostiku.
    • V části Diagnostikasítě>odstraňování problémů >
      • Odebere se také testování přístupu k webu (které vyžadovalo externí adresu URL, například www.dell.com)
      • Zachoval PING a DNS kroky řešení, přidána hláška, že uživatel musí kliknout na tlačítko Pokračovat
        • Dříve musel uživatel kliknout na možnost Diagnostics
        • Nyní musí uživatel kliknout na tlačítko Diagnostics and Continue
          Uživatel musí kliknout na tlačítko Pokračovat.

Affected Products

Latitude 3420, Latitude 3440, Latitude 5440, OptiPlex 3000 Thin Client, OptiPlex 5400 All-In-One, OptiPlex All-In-One 7410, Wyse 3040 Thin Client, Wyse 5070 Thin Client, Wyse 5470 All-In-One, Wyse 5470, Dell ThinOS
Article Properties
Article Number: 000217192
Article Type: Solution
Last Modified: 24 Apr 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.