NetWorker: FLR för virtuell maskin misslyckas konsekvent med "Det gick inte att hämta kataloginnehållet..."
Summary: Återställningen på filnivå (FLR) för virtuella Windows-datorer misslyckas konsekvent. FLR-monteringen lyckas, men bläddringen misslyckas för 3–4 mappar med meddelandet "Det gick inte att hämta kataloginnehållet, det går inte att hämta fillistan från VM (sökväg) Åtkomst nekad". ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Från loggen /opt/emc/vproxy/runtime/logs/vflrd/mount-e28###a6-2##2-4##e-b##8-b900####2bd7.log:
YYYY-MM-DDTHH:MM:SSZ INFO: [29] ====End of output from agent mount. YYYY-MM-DDTHH:MM:SSZ INFO: [29] Successfully mounted VMDKs onto VM 'my_vmname' (vm-####) filesystem hierarchy at 'C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLR65####027'. YYYY-MM-DDTHH:MM:SSZ INFO: [29] End of mount request processing; mountpoint is 'C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLR65####027' (no error) YYYY-MM-DDTHH:MM:SSZ INFO: [29] Disconnected from session on vCenter 'myvcenter.com'. YYYY-MM-DDTHH:MM:SSZ INFO: [29] Adding FlrBrowseSessions session 'cb###4c0-7##0-4##9-b##1-711#####a983'
Från loggen /opt/emc/vproxy/runtime/logs/vflrd/browse-cb0###c0-7##0-4##9-b##1-7116#####983.log:
YYYY-MM-DDTHH:MM:SSZ ERROR: [29] FLR:browse_files: Unable to perform FLR Agent operation 'browse_files' on VM IP Address: ##.##.##.## (vm-####). YYYY-MM-DDTHH:MM:SSZ ERROR: [29] Unable to retrieve file list from ##.##.##.## (vm-####) path 'F:\DFS-SHARE\Administration\MY_FOLDER' offset 0. YYYY-MM-DDTHH:MM:SSZ ERROR: [29] Could not get directory contents: Unable to retrieve file list from ##.##.##.## (vm-####) path '#:\DFS-SHARE\Administration\MY_FOLDER' offset 0. Unable to perform FLR Agent operation 'browse_files' on VM ##.##.##.## (vm-####). Cannot stat 'C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLR65####027\02-#$\DFS-SHARE\Administration\MY_FOLDER': CreateFile C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLR65####027\02-F$\DFS-SHARE\Administration\EXE_ADMIN: Access is denied. YYYY-MM-DDTHH:MM:SSZ ERROR: [29] FLR:browse_files: Cannot stat 'C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLR65####027\02-#$\DFS-SHARE\Administration\MY_FOLDER': CreateFile C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLR65####027\02-#$\DFS-SHARE\Administration\MY_FOLDER: Access is denied.
Cause
- De virtuella datorer som misslyckades för FLR med ovanstående symptom använder Microsoft Distributed File System (DFS).
- Microsoft DFS är en Windows-filsystemfunktion som gör det möjligt för användare att skapa ett namnområde för delade kataloger som distribueras fysiskt i ett nätverk. Med DFS kan användare organisera en grupp distribuerade kataloger logiskt, enligt valfritt schema, för att ge centraliserad åtkomst till filer som finns på olika platser.
- Mer information om Microsoft DFS finns i Microsoft-artikeln Översikt över DFS-namnområden.
Resolution
- NetWorker NVP vProxy – Virtual Machine File Level Recovery (FLR) stöder inte DFS (Windows Distributed File System).
- Dell Engineering har identifierat att vProxy FLR inte stöder Microsoft Distributed File System (DFS)
- En kommande version av NetWorker VMware Integration Guide för version 19.8 och 19.9 planeras för att åtgärda den här begränsningen.
Alternativ lösning:
- Initiera filnivååterställning (FLR) från NetWorker Management Console-gränssnittet (NMC).
- Montera FLR (File Level Recovery) i NetWorker Management Console (NMC) UI Titel på återställningssidan: Montera spara-uppsättningen för återställning av filnivå
- Lämna FLR-monteringspunkten (File Level Recovery) i monterat läge i användargränssnittet för NetWorker Management Console (NMC).
- Använd Utforskaren för att kopiera och klistra in kataloginnehållet på den virtuella måldatorn (DFS) för distribuerat filsystem (DFS).
Article Properties
Article Number: 000217445
Article Type: Solution
Last Modified: 16 Oct 2024
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.