NetWorker Module for Microsoft: SQL AlwaysOn Availability Group Cluster with Two Nodes, Client Wizard Does Not Configure Listener or Cluster Name.

Summary: SQL AlwaysOn Availability Group (AAG) Cluster with two nodes, Client Wizard does not configure listener or cluster name.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker Module for Microsoft (NMM) SQL ALlwaysOn Availability Group (AAG) Cluster with two nodes, Azure, Client Wizard fails to configure listener or cluster name.

Backup also fails with manually configured client, exit code 1.

Wizard fails with Dispatcher timed out message box.

Cause

Since the NetWorker server is on the same subnet as the two SQL clients, for example, all IP addresses in same subnet n.n.n.0, firewalls are not causing this.

In the server daemon.raw, notice the following message:
2023-09-28 07:02:59 AM   BACKUPSERVER nsrexecd error Unable to create the connection with 'nsrexec' to host 'LISTENER_FQDN'  with address 'N.N.N.X' at port number 7940.
Investigation determined that the service port range on nsrexecd service on one of the clients was too small. For example:
SERVER PORT RANGE is CORRECT DEFAULTS

service ports: 7937-9936;
type: NSR system port ranges;

CLIENT 01 IS CORRECT 
service ports: 7937-9936;
type: NSR system port ranges;

CLIENT NODE 02 IS TOO SMALL 
service ports: 7937-7944;
type: NSR system port ranges;

Resolution

Steps to correct this:
  1. Run the following command immediately on the node with the issue:
  nsrports -S  7937-9936
  1. Restart nsrexecd service on the same node as a precaution.
  2. Run the backup or client wizard.
Article Properties
Article Number: 000218108
Article Type: Solution
Last Modified: 06 Oct 2023
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.