Windows Server: Errore di desktop remoto quando si stabilisce una connessione desktop remoto

Summary: Quando gli utenti tentano di stabilire una connessione Desktop remoto a un server, potrebbe essere visualizzato il seguente messaggio di errore: "La sessione remota è stata disconnessa perché non sono disponibili server licenze Desktop remoto per fornire una licenza." ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Quando gli utenti tentano di stabilire una connessione Desktop remoto a un server, potrebbe essere visualizzato il seguente messaggio di errore:

"La sessione remota è stata disconnessa perché non sono disponibili server licenze Desktop remoto per fornire una licenza".

 

  • Gestione licenze Desktop remoto indica che le licenze CAL (Client Access License) Desktop remoto (RD) sono installate nel server licenze.
  • Remote Desktop License Diagnoser indica che è in uso il server licenze corretto.
  • In particolare, le licenze CAL Desktop remoto elencate in Gestione licenze Desktop remoto non elencano una versione del sistema operativo, come mostrato in questa immagine:
    Schermata di Gestione licenze Desktop remoto, che mostra le licenze CAL senza versione del sistema operativo Figura 1. Screenshot di Remote Desktop Licensing Manager che mostra le licenze CAL installate senza versione del sistema operativo

 

Nota: Questo articolo affronta una situazione specifica, anche se lo stesso errore può verificarsi in altre situazioni. Esaminare le informazioni nella sezione Sintomi per verificare che questo articolo sia applicabile.

Cause

Ciò si verifica se le licenze CAL di Desktop remoto installate sono per una versione più recente del sistema operativo rispetto al sistema operativo in esecuzione sul server licenze di Desktop remoto. Ad esempio, se il server licenze esegue Windows Server 2019 e sono installate licenze CAL di Windows Server 2022 RD, si verifica questo errore.

Resolution

Esistono tre modi per risolvere questo problema:
  • Aggiornare il sistema operativo sul server licenze in modo che corrisponda alla versione delle licenze CAL di Desktop remoto installate. Ciò richiede una licenza di Windows Server valida e inutilizzata e un codice Product Key.
  • Installare il servizio ruolo Licenze Desktop remoto su un server esistente che esegue il sistema operativo più recente. Eseguire la migrazione delle licenze CAL Desktop remoto su di esso e configurare la distribuzione di Servizi Desktop remoto per utilizzarla come server licenze.
  • Contattare Microsoft Clearinghouse e eseguire il downgrade delle licenze CAL di Desktop remoto alla versione in esecuzione sul server licenze. Il supporto Dell può aiutare a contattare Microsoft Clearinghouse.

Affected Products

Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022

Products

C Series, HS Series, Modular Infrastructure, Rack Servers, Tower Servers, XE Servers, XR Servers, OEM Server Solutions
Article Properties
Article Number: 000218177
Article Type: Solution
Last Modified: 09 Dec 2024
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.