Windows Server: Błąd 4012 pojawia się w dzienniku zdarzeń replikacji systemu plików DFS kontrolera domeny usługi Active Directory

Summary: Jeśli kontroler domeny (DC) usługi Active Directory nie może replikować danych SYSVOL od partnera przez dłuższy czas, replikacja SYSVOL zostanie zatrzymana. Błąd 4012 jest rejestrowany w dzienniku zdarzeń replikacji rozproszonego systemu plików (DFSR) kontrolera domeny, którego dotyczy problem. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Błąd 4012 (źródło: DFSR) pojawia się w rejestrze zdarzeń DFSR kontrolera domeny. Opis zdarzenia zawiera ścieżkę folderu SYSVOL, jak pokazano poniżej:

The DFS Replication service stopped replication on the folder with the following local path: C:\Windows\SYSVOL\domain. This server has been disconnected from other partners for n days, which is longer than the time allowed by the MaxOfflineTimeInDays parameter (60). DFS Replication considers the data in this folder to be stale, and this server will not replicate the folder until this error is corrected.

[The rest of the event description has been omitted.]

Ścieżka lokalna może się różnić, ale ten artykuł ma zastosowanie tylko wtedy, gdy jest mowa o folderze SYSVOL. W powyższym przykładzie n wskazuje liczbę dni, przez które kontroler domeny nie mógł skontaktować się z partnerem. Liczba ta jest różna, ale zawsze większa niż wartość MaxOfflineTimeInDays.

Cause

Replikacja w rozproszonym systemie plików (DFSR) wymaga regularnego komunikowania się partnerów replikacji. Jeśli serwer nie może komunikować się z partnerem przez dłuższy czas, replikacja jest wyłączona na tym serwerze.

MaxOfflineTimeInDays, który ma wartość domyślną 60, reprezentuje najdłuższy dozwolony czas, przez jaki serwery nie są ze sobą połączone. Jest to analogiczne do okresu istnienia reliktu lasu usługi Active Directory, choć jest od niego oddzielone.

Resolution

Uwaga: Zignoruj fragment opisu zdarzenia, który mówi o usunięciu serwera z grupy replikacji i ponownym jego dodaniu Nie jest to prawidłowa procedura w przypadku replikacji SYSVOL.


Scenariusz 1: W domenie znajduje się tylko jeden kontroler domeny.

Jeśli w domenie znajduje się tylko jeden kontroler domeny, autorytatywna synchronizacja folderu SYSVOL jest niezbędna w celu zapewnienia replikacji w przypadku dodania innego. W tym zakresie zapoznaj się z tematem Wykonywanie autorytatywnej synchronizacji danych SYSVOL przy użyciu replikacji w rozproszonym systemie plików (DFSR). Wszystkie kroki, które wspominają o innych kontrolerach domeny lub wymuszaniu replikacji, mogą zostać pominięte.


Scenariusz 2: W domenie znajduje się wiele kontrolerów domeny.

Jeśli w domenie znajduje się wiele kontrolerów domeny, konieczne jest określenie, ilu z nich dotyczy problem. W tym celu przeszukuje dzienniki zdarzeń DFSR kontrolerów domeny pod kątem błędu 4012. Wszystkie kontrolery domeny, których dotyczy problem, mają ten błąd w swoich dziennikach w niedawnej przeszłości.

  • Jeśli problem dotyczy tylko jednego kontrolera domeny, przeprowadź na nim nieautorytatywną synchronizację SYSVOL. W tym zakresie zapoznaj się z tematem Wykonywanie nieautorytatywnej synchronizacji danych SYSVOL przy użyciu replikacji w rozproszonym systemie plików (DFSR).
  • Jeśli problem dotyczy wielu kontrolerów domeny, ale istnieją inne kontrolery domeny, których nie dotyczy problem, przeprowadź nieautorytatywną synchronizację SYSVOL na wszystkich kontrolerach domeny, których dotyczy problem.
  • Jeśli problem dotyczy wszystkich kontrolerów domeny w domenie, należy wybrać jeden z nich jako autorytatywne źródło danych SYSVOL. Wymaga to sprawdzenia danych w hierarchii folderów SYSVOL każdego kontrolera domeny i określenia, która kopia jest najbardziej aktualna. Po wybraniu autorytatywnego źródła przeprowadź autorytatywną synchronizację SYSVOL na tym kontrolerze domeny. Zobacz scenariusz 1 powyżej, aby uzyskać łącze do kroków. Wykonaj wszystkie czynności procedury, aby zsynchronizować SYSVOL na wszystkich kontrolerach domeny w domenie.

Additional Information

W domenie z wieloma kontrolerami domeny może być również możliwe wznowienie replikacji na kontrolerze domeny, którego dotyczy problem, przez zwiększenie wartości MaxOfflineTimeInDays. Nie zostało to gruntownie przetestowane, ale wielokrotnie rozwiązało problem. Aby ustawić MaxOfflineTimeInDays, uruchom to polecenie:

wmic.exe /namespace:\\root\microsoftdfs path DfsrMachineConfig set MaxOfflineTimeInDays=x

Wartość x musi być większa niż liczba dni wskazana w błędzie 4012. Po uruchomieniu polecenia uruchom ponownie usługę replikacji DFS i sprawdź, czy w dzienniku zdarzeń replikacji systemu plików DFS nie ma błędów. Jeśli replikacja nie działa już od jakiegoś czasu, spodziewane są zdarzenia związane z wykrywaniem i rozwiązywaniem konfliktów. Wskazują one, że DFSR działa zgodnie z założeniami.

Po wznowieniu replikacji uruchom ponownie polecenie z wartością 60, aby zwrócić MaxOfflineTimeInDays do wartości domyślnej. (Jest to opcjonalne).

Affected Products

Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022, Microsoft Windows Server 2025

Products

PowerEdge R250, PowerEdge R260, PowerEdge R350, PowerEdge R360, PowerEdge R450, PowerEdge R550, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R750 , PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R860, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640 ...
Article Properties
Article Number: 000218367
Article Type: Solution
Last Modified: 28 Apr 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.