Windows Server: Active Directory Etki Alanı Denetleyicisinin DFS Çoğaltma Olay Günlüğünde Hata 4012 Görünüyor

Summary: Active Directory etki alanı denetleyicisi (DC), bir ortaktan gelen SYSVOL verilerini uzun süre çoğaltamazsa SYSVOL çoğaltması durur. Bu gerçekleştiğinde, etkilenen DC'nin Dağıtılmış Dosya Sistemi Çoğaltması (DFSR) olay günlüğüne 4012 hatası kaydedilir. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Hata 4012 (kaynak: DFSR) bir DC'nin DFSR olay günlüğünde görünür. Olay açıklaması, burada gösterildiği gibi SYSVOL klasör yolunu içerir:

The DFS Replication service stopped replication on the folder with the following local path: C:\Windows\SYSVOL\domain. This server has been disconnected from other partners for n days, which is longer than the time allowed by the MaxOfflineTimeInDays parameter (60). DFS Replication considers the data in this folder to be stale, and this server will not replicate the folder until this error is corrected.

[The rest of the event description has been omitted.]

Yerel yol değişebilir ancak bu makale yalnızca SYSVOL klasöründen bahsediyorsa geçerlidir. Yukarıdaki örnekte n , DC'nin bir iş ortağıyla iletişim kuramadığı gün sayısını gösterir. Bu sayı değişir ancak her zaman MaxOfflineTimeInDaysIP adresi için sorgular.

Cause

Dağıtılmış Dosya Sistemi Çoğaltması (DFSR), çoğaltma ortaklarının düzenli iletişim içinde olmasını gerektirir. Bir sunucu bir ortakla uzun süre iletişim kuramazsa o sunucuda çoğaltma devre dışı bırakılır.

MaxOfflineTimeInDays, varsayılan değeri 60 olan sunucuların birbirleriyle iletişimsiz kalması için izin verilen en uzun süreyi temsil eder. Bu, Active Directory ormanının kaldırıldı işareti ömrüne benzer, ancak ondan ayrıdır.

Resolution

Not: Olay açıklamasının, sunucuyu çoğaltma grubundan kaldırıp yeniden eklemenizi söyleyen kısmını yok sayın. SYSVOL çoğaltması söz konusu olduğunda bu doğru bir prosedür değildir.


1. Senaryo: Etki alanında yalnızca bir DC var.

Etki alanında yalnızca bir DC varsa, başka bir DC eklendiğinde çoğaltmanın gerçekleştiğinden emin olmak için yetkili bir SYSVOL senkronizasyonu gerekir. İlgili adımlar için Dağıtılmış Dosya Sistemi Çoğaltması (DFSR) Kullanarak SYSVOL Verilerinin Yetkili Senkronizasyonunu Gerçekleştirme bölümüne bakın. Diğer DC'lerden bahseden veya çoğaltmayı zorlayan tüm adımlar atlanabilir.


2. Senaryo: Etki alanında birden fazla DC var.

Etki alanında birden fazla DC varsa kaç tanesinin sorundan etkilendiğini belirlemek gerekir. Bunu yapmak için DC'lerin DFSR olay günlüklerinde 4012 hatası olup olmadığını kontrol edin. Etkilenen tüm DC'lerin yakın geçmişteki günlüklerinde bu hata var.

  • Yalnızca bir DC etkilenirse bu DC'de yetkisiz bir SYSVOL senkronizasyonu gerçekleştirin. İlgili adımlar için Dağıtılmış Dosya Sistemi Çoğaltması (DFSR) Kullanarak SYSVOL Verilerinin Yetkisiz Senkronizasyonunu Gerçekleştirme başlıklı makaleye bakın.
  • Birden fazla DC etkileniyor ancak etkilenmeyen başka DC'ler varsaetkilenen tüm DC'lerde SYSVOL'ün yetkisiz senkronizasyonunu gerçekleştirin.
  • Etki alanındaki tüm DC'ler etkilenirse yetkili SYSVOL veri kaynağı olarak bir DC seçilmelidir. Bunun için her DC'nin SYSVOL klasör hiyerarşisindeki verilerin incelenmesi ve hangi kopyanın en güncel olduğunun belirlenmesi gerekir. Yetkili bir kaynak seçildikten sonra, bu DC'de SYSVOL'ün yetkili senkronizasyonunu gerçekleştirin. Adımların bağlantısı için yukarıdaki Senaryo 1'e bakın. SYSVOL'ü etki alanındaki tüm DC'lerde senkronize etmek için prosedürün tüm adımlarını gerçekleştirin.

Additional Information

Çoklu DC etki alanında, etkilenen DC'de çoğaltmaya devam etmek için MaxOfflineTimeInDaysIP adresi için sorgular. Bu, kapsamlı bir şekilde test edilmemiştir ancak sorunu birçok kez çözmüştür. Ayarlamak için MaxOfflineTimeInDays, şu komutu çalıştırın:

wmic.exe /namespace:\\root\microsoftdfs path DfsrMachineConfig set MaxOfflineTimeInDays=x

x değeri, hata 4012'de belirtilen gün sayısından büyük olmalıdır. Komutu çalıştırdıktan sonra DFS Kopya hizmetini yeniden başlatın ve DFS Çoğaltma olay günlüğünde hata olup olmadığını kontrol edin. Çoğaltma bir süredir başarısız oluyorsa, çakışma algılama ve çözümleme ile ilgili olaylar beklenir. DFSR'nin tasarlandığı gibi çalıştığını gösterir.

Çoğaltma devam ettikten sonra döndürmek için komutu 60 değeriyle tekrar çalıştırın MaxOfflineTimeInDays varsayılan değerine. (Bu isteğe bağlıdır.)

Affected Products

Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022, Microsoft Windows Server 2025

Products

PowerEdge R250, PowerEdge R260, PowerEdge R350, PowerEdge R360, PowerEdge R450, PowerEdge R550, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R750 , PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R860, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640 ...
Article Properties
Article Number: 000218367
Article Type: Solution
Last Modified: 28 Apr 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.