Windows Server: L'errore 4012 viene visualizzato nel registro eventi di replica DFS di un controller di dominio Active Directory

Summary: Se un controller di dominio (DC) Active Directory non è in grado di replicare i dati SYSVOL da un partner per un lungo periodo di tempo, la replica SYSVOL si interrompe. Quando si verifica questo problema, l'errore 4012 viene registrato nel registro eventi DFSR (Distributed File System Replication) del controller di dominio interessato. ...

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Symptoms

Errore 4012 (fonte: DFSR) viene visualizzato nel registro eventi DFSR di un DC. La descrizione dell'evento include il percorso della cartella SYSVOL, come illustrato di seguito:

The DFS Replication service stopped replication on the folder with the following local path: C:\Windows\SYSVOL\domain. This server has been disconnected from other partners for n days, which is longer than the time allowed by the MaxOfflineTimeInDays parameter (60). DFS Replication considers the data in this folder to be stale, and this server will not replicate the folder until this error is corrected.

[The rest of the event description has been omitted.]

Il percorso locale può variare, anche se questo articolo si applica solo se menziona la cartella SYSVOL. Nell'esempio precedente, n indica il numero di giorni in cui il controller di dominio non è stato in grado di contattare un partner. Questo numero varia, ma è sempre maggiore del valore di MaxOfflineTimeInDays.

Cause

La DFSR (Distributed File System Replication) richiede che i partner di replica comunichino regolarmente. Se un server non è in grado di comunicare con un partner per un lungo periodo di tempo, la replica viene disabilitata su tale server.

MaxOfflineTimeInDays, che ha un valore predefinito pari a 60, rappresenta il tempo più lungo consentito per l'interruzione della comunicazione tra i server. Si tratta di un percorso analogo, anche se separato, alla durata di rimozione definitiva di una foresta di Active Directory.

Resolution

Nota: Ignorare la parte della descrizione dell'evento che indica di rimuovere il server dal gruppo di replica e aggiungerlo nuovamente. Questa non è la procedura corretta quando si gestisce la replica SYSVOL.


Scenario 1: Nel dominio è presente un solo controller di dominio.

Se nel dominio è presente un solo controller di dominio, è necessaria una sincronizzazione autorevole di SYSVOL per garantire che la replica si verifichi se ne aggiunge un altro. Vedere Come eseguire una sincronizzazione autorevole dei dati SYSVOL utilizzando DFSR (Distributed File System Replication) per la procedura. Tutti i passaggi che menzionano altri controller di dominio o forzano la replica possono essere ignorati.


Scenario 2: Nel dominio sono presenti più DC.

Se nel dominio sono presenti più DC, è necessario determinare quanti sono interessati dal problema. A tale scopo, cercare l'errore 4012 nei registri eventi DFSR dei controller di dominio. Tutti i controller di dominio interessati presentano questo errore nei propri registri nel recente passato.

  • Se è interessato un solo DC, eseguire una sincronizzazione non autorevole di SYSVOL su tale DC. Vedere Come eseguire una sincronizzazione non autorevole dei dati SYSVOL utilizzando DFSR (Distributed File System Replication) per la procedura.
  • Se sono interessati più DC ma altri DC non interessati, eseguire una sincronizzazione non autorevole di SYSVOL su tutti i DC interessati.
  • Se sono interessati tutti i controller di dominio del dominio, è necessario sceglierne uno come origine autorevole dei dati SYSVOL. Ciò richiede l'ispezione dei dati nella gerarchia di cartelle SYSVOL di ogni DC e la determinazione della copia più recente. Una volta scelta un'origine autorevole, eseguire una sincronizzazione autorevole di SYSVOL su tale DC. Vedere lo scenario 1 precedente per un collegamento alla procedura. Eseguire tutti i passaggi della procedura per sincronizzare SYSVOL su tutti i controller di dominio del dominio.

Additional Information

In un dominio con più DC, potrebbe anche essere possibile riprendere la replica in un DC interessato aumentando il valore di MaxOfflineTimeInDays. Questo non è stato testato in modo approfondito, ma ha risolto il problema in più occasioni. Per impostare MaxOfflineTimeInDays, eseguire questo comando:

wmic.exe /namespace:\\root\microsoftdfs path DfsrMachineConfig set MaxOfflineTimeInDays=x

Il valore x deve essere maggiore del numero di giorni indicati nell'errore 4012. Riavviare il servizio DFS Replication dopo l'esecuzione del comando e controllare la presenza di errori nel registro eventi di DFS Replication. Se la replica ha esito negativo per un certo periodo di tempo, sono previsti eventi relativi al rilevamento e alla risoluzione dei conflitti. Indicano che DFSR funziona come previsto.

Una volta ripresa la replica, eseguire nuovamente il comando con un valore pari a 60 per restituire MaxOfflineTimeInDays al suo valore predefinito. (Questa opzione è opzionale).

Affected Products

Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022, Microsoft Windows Server 2025

Products

PowerEdge R250, PowerEdge R260, PowerEdge R350, PowerEdge R360, PowerEdge R450, PowerEdge R550, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R750 , PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R860, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640 ...
Article Properties
Article Number: 000218367
Article Type: Solution
Last Modified: 28 Apr 2025
Version:  6
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