NetWorker: No se pueden ver los ID de cliente para todos los clientes después de utilizar nsrdr

Summary: Después de utilizar nsrdr para migrar o recuperar el servidor de NetWorker, el atributo de ID de cliente ya no es visible para todos los clientes.

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Symptoms

El servidor de NetWorker se migró a un nuevo host o se recuperó desde el respaldo de bootstrap mediante el comando nsrdr. Después de la recuperación ante desastres, faltan valores de ID de cliente en la vista NetWorker Management Console (NMC). El atributo hostname también aparece en blanco en lugar de tener el nombre del servidor de NetWorker:
 
Vista de la consola de administración de NetWorker
Figura 1: Vista de la consola de administración de NetWorker
 
Propiedades del cliente
Figura 2 Propiedades del cliente

Los ID de cliente están disponibles en la base de datos de medios incluso para los respaldos nuevos y se pueden comprobar mediante el siguiente comando:
mminfo
Compruebe el ID del cliente mediante el comando mminfo
Figura 3: Compruebe el ID del cliente mediante el comando mminfo.
 
Los ID de cliente no aparecen en la base de datos de recursos cuando se comprueban mediante lo siguiente: 
nsradmin
Comprobar el ID del cliente mediante la utilidad nsradmin
Figura 4: Compruebe el ID de cliente mediante la utilidad nsradmin.

En el registro de demonio del servidor NetWorker, se registran los siguientes mensajes durante el inicio del servicio:
DD/MM/YYYY HH:MM:SS  1 5 0 11092 11088 0 networkersrv01.demo.local nsrd NSR notice The fast system restart of NetWorker is enabled. DNS cache will not be populated and RAP check of the clients will be skipped. 
DD/MM/YYYY HH:MM:SS  1 5 0 11092 11088 0 networkersrv01.demo.local nsrd NSR notice Skipping populating DNS cache as disaster recovery is in progress ... 

Cause

nsr_disaster_recovery_mode archivo existe en el directorio /nsr/debug. Este archivo se crea como parte del procedimiento nsrdr. Habilita el reinicio del sistema de archivos del servidor de NetWorker mediante la deshabilitación de las búsquedas de DNS, lo que hace que los ID de cliente falten o no se carguen en la base de datos de recursos durante el inicio del servicio.

En las operaciones normales de DR, este archivo se debe eliminar al final del proceso de inicio. Sin embargo, en caso de que se encuentre una falla o que nsrdr no se complete correctamente, este archivo se puede dejar en el directorio /nsr/debug que requiere la eliminación manual.

Resolution

Realice los siguientes pasos para deshabilitar el modo de RECUPERACIÓN ante desastres o el reinicio rápido del sistema cuando no hay actividades de NetWorker en ejecución:
  1. Detenga los servicios de NetWorker:
Windows:    net stop nsrd
Linux:      systemctl stop networker
  1. Cambie el nombre o elimine el archivo "nsr_disaster_recovery_mode" del directorio /nsr/debug.
  2. Reiniciar Servicios de NetWorker:
Windows:    net start nsrd
Linux:      systemctl start networker

Additional Information

Affected Products

NetWorker
Article Properties
Article Number: 000218693
Article Type: Solution
Last Modified: 31 Oct 2023
Version:  2
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