mksysb リストアがエラー 0301-165 bosboot failed で失敗する

Summary: この記事は、同様のIBMの記事に基づいていますが、ここではPowerPathのコンテキストに合わせて変更されています。PowerPathをインストールしてmksysbイメージを作成した場合、マルチパス対応ディスク上のイメージのリストアが失敗することがあります。これは、複数のhdiskがrootvgを保持しているため、bosbootが正常に動作しないためです。この記事 では、この問題を解決するために必要なすべての手順について説明します。 ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

mksysb リストアがエラー 0301-165 bosboot failed で失敗します
mksysb をリストアしようとするときに、イメージの復元に使用されるデバイスに対して複数のパスが構成されていると、以下のようなエラーが発生することがあります。
0301-165 bosboot: WARNING! bosboot failed - do not attempt to boot device.
BOS Install: Could not create boot image.
   ID#        OPTION
     1        Continue
     2        Perform System Maintenance and Then Continue
   Enter ID number:

Cause

rootvgはSANディスク上に存在し、複数のパスが構成され、PowerPathによって処理されます。このような場合、同じPVIDで複数のhdiskが作成され、bosbootコマンドが失敗します。

Resolution

rootvgをサポートするデバイスを一覧表示します
これらのhdiskを保持している疑似デバイスを見つけます。
デバイスをPowerPath.
から解放します。hdiskを削除します(1つを除くすべて)
残りのhdiskに対してbosbootコマンドを実行します。
ipldeviceに対してbosbootを実行します。
mksysb リストアが失敗した場合は、終了

オプション 2 を選択します。
0301-165 bosboot: WARNING! bosboot failed - do not attempt to boot device.
BOS Install: Could not create boot image.
   ID#        OPTION
     1        Continue
     2        Perform System Maintenance and Then Continue
   Enter ID number: 2

rootvgディスクを確認します。
# lspv |grep rootvg
hdisk0          00aabbccddeeffcc                    rootvg          active
hdisk2          00aabbccddeeffcc                    rootvg          active
hdisk4          00aabbccddeeffcc                    rootvg          active
hdisk6          00aabbccddeeffcc                    rootvg          active
hdisk8          00aabbccddeeffcc                    rootvg          active
hdisk10         00aabbccddeeffcc                    rootvg          active
hdisk12         00aabbccddeeffcc                    rootvg          active
hdisk14         00aabbccddeeffcc                    rootvg          active

次のリストから任意のhdiskデバイスを使用して、対応する疑似デバイスを見つけます。
# powermt display dev=hdisk0

Pseudo name=hdiskpower0
Symmetrix ID=000297000000
Logical device ID=0000013C
Device WWN=60000970000297000000533030313343
state=alive; policy=SymmOpt; queued-IOs=0
==============================================================================
--------------- Host ---------------   - Stor -  -- I/O Path --   -- Stats ---
###  HW Path               I/O Paths    Interf.  Mode     State   Q-IOs Errors
==============================================================================
   3 fscsi7                 hdisk0     FA  3d:04 active   alive      0      0
   3 fscsi7                 hdisk2     FA  1d:04 active   alive      0      0
   2 fscsi6                 hdisk4     FA  4d:04 active   alive      0      0
   2 fscsi6                 hdisk6     FA  6d:04 active   alive      0      0
   2 fscsi6                 hdisk8     FA  2d:08 active   alive      0      0
   1 fscsi5                 hdisk10    FA  3d:04 active   alive      0      0
   1 fscsi5                 hdisk12    FA  1d:04 active   alive      0      0
   0 fscsi4                 hdisk14    FA  4d:04 active   alive      0      0


疑似デバイスを削除してhdiskを解放します

# powermt remove dev=hdiskpower0

重複したrootvgディスクを削除します。

# rmdev -dl hdisk0
# rmdev -dl hdisk2
# rmdev -dl hdisk4
# rmdev -dl hdisk6
# rmdev -dl hdisk8
# rmdev -dl hdisk10
# rmdev -dl hdisk12
# rmdev -dl hdisk14

上記の rmdev コマンドの 1 つが予期どおりに失敗し、rootvg ディスクが 1 つだけ残ります。
# lspv |grep rootvg
hdisk12         00aabbccddeeffcc                    rootvg          active

bosbootコマンドを手動で実行します。
# bosboot -ad /dev/hdisk12
# bosboot -ad /dev/ipldevice

(「bosboot -ad /dev/ipldevice」コマンドを成功させるには、ipldeviceを作成する必要がある場合があります。この場合、これは "ln /dev/rhdisk12 /dev/ipldevice" で行います。

bosbootコマンドが機能する場合は、「exit」と入力します

# exit

mksysb リストアは引き続き完了します

bosbootコマンドが失敗した場合は、ストレージ管理者と協力して、mksysbリストアの前にrootvgディスクのパス数を1つに減らします。

このソリューションは、IBMのパブリック ソリューション https://www.ibm.com/support/pages/mksysb-restore-fails-error-0301-165-bosboot-failed から派生したものです

Affected Products

PowerPath for AIX
Article Properties
Article Number: 000219423
Article Type: Solution
Last Modified: 15 Nov 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.