PowerFlex 4.5 - Dağıtım sırasında hata "Sunucu Yapılandırma Profili ağ paylaşımına kopyalanamıyor."

Summary: PowerFlex 4.5 - Dağıtım sırasında hata "Sunucu Yapılandırma Profili ağ paylaşımına kopyalanamıyor."

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PowerFlex Manager Platform (PFMP) Thin Deployer Günlüklerinde Hata:

Debug: Result = #\n\n  \n    http://schemas.xmlsoap.org/ws/2004/08/addressing/role/anonymous\n    http://schemas.xmlsoap.org/ws/2004/09/transfer/GetResponse\
n    uuid:55c86fb7-0a34-1a34-8002-c3e575a07eee\n    uuid:5d393a92-0a39-1a39-81bf-4e1296d64bc8\n  \n  \n    \n      0\n      JID_000913530199\n      NA\n   
   Failed\n      NA\n      Unable to copy the Server Configuration Profile to the network share.\n      NA\n      SYS045\n      Export Configuration\n   
   100\n    \n  \n\n">

Dağıtım sırasında PowerFlex Manager hatası:


RG Hatası 


 

 

Cause

Klasör İzinleri dağıtım sırasında doğru ayarlanmamış.

Resolution

Geçici Çözüm

nfs-server-0 kullanıma sunulan hizmet bağlantı noktasına
test bağlantısı başarılı NFS ye gidin ve NFS'nin doğru yapılandırıldığını ve gerekli tüm bağlantı noktalarının açık olduğunu doğrulamak için Yaşam Döngüsü Günlüğünü NFS paylaşımına aktarmayı deneyin.

IP Adresini, aşağıdaki ekran görüntüsünde OOB nfs-server-service-tcp-flex-oob-mgmt-r yönlendirilebilir IP adresinin IP adresiyle değiştirin.

Kubectl get service -n powerflex | grep nfs", nfs-server-service-tcp-flex-oob-mgmt-r yönlendirilebilir IP adresini almak için kullanılır.

Paylaşım Yolu şu şekildedir: /var/containerpath/idrac_config_xml


image.png

NFS doğru yapılandırılmamışsa ve sorunlar varsa iş, "Ağ paylaşımına yazılamadığı için iş JID_XXXXXXXXXXX başarısız oldu" hatasıyla başarısız olur


iDRAC iş kimliği 

Aşağıdaki Bağlantı Noktalarının açık olduğunu doğrulayın: -

Port 111 (TCP and UDP)
Port 2049 (TCP and UDP)
Port 32765 (TCP and UDP)
Port 32767 (TCP and UDP)


Bundan sonra, önceki adımda NFS paylaşımına Yaşam Döngüsü Günlüklerini Dışa Aktarma işleminin başarısız olduğu iDRAC ın IP adresine sahip yukarıdaki bağlantı noktalarının her biri için aşağıdaki komutu çalıştırın.

echo > /dev/tcp/XX.XX.XX.XX/111 && echo "Port is open" || echo "not open"
echo > /dev/tcp/XX.XX.XX.XX/2049 && echo "Port is open" || echo "not open"
echo > /dev/tcp/XX.XX.XX.XX/32765 && echo "Port is open" || echo "not open"
echo > /dev/tcp/XX.XX.XX.XX/32767 && echo "Port is open" || echo "not open"
echo > /dev/udp/XX.XX.XX.XX/111 && echo "Port is open" || echo "not open"
echo > /dev/udp/XX.XX.XX.XX/2049 && echo "Port is open" || echo "not open"
echo > /dev/udp/XX.XX.XX.XX/32765 && echo "Port is open" || echo "not open"
echo > /dev/udp/XX.XX.XX.XX/32767 && echo "Port is open" || echo "not open"




Bağlantı noktası açık kontrolü 

Tüm bağlantı noktalarının açık olduğunu doğruladıktan sonra, iDRAC NFS paylaşımına YAZILAMADIĞINDAN odağı izinler olarak değiştirin. Ancak IDRAC buna bağlanabilir.

/opt/platform/fileshare/ klasörüne gidin ve idrac_config_xml üzerindeki klasör izinlerini kontrol edin.

drwxrwxrwx 1 kimse kimse
olarak ayarlanmalıdır Aşağıdaki ekran görüntüsünde, klasör izinlerinin drwxr-xr-x 1 kök kökü olarak ayarlandığını fark edebilirsiniz. Bunlar doğru izinler değildir.


image.png

Aşağıdaki komutları çalıştırarak izinleri değiştirin.

chmod 777 /opt/platform/fileshare/idrac_config_xml
chown nobody:nobody /opt/platform/fileshare/idrac_config_xml

İzinler doğru bir şekilde ayarlandıktan sonra drwxrwxrwx 1 hiç kimse /opt/platform/fileshare/idrac_config_xml klasöründe kimse.

kubectl exec -it nfs-server-0 -n powerflex -- /bin/bash" komutunu  çalıştırın ve /var/containerpath klasörüne giderek idrac_config_xml klasördeki klasör izinlerini kontrol edin. Artık klasör izinlerinin bu klasörde de doğru şekilde ayarlandığını fark ettiniz.


image.png

 

Article Properties
Article Number: 000219658
Article Type: Solution
Last Modified: 10 Feb 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.