Data Protection Advisor: NetWorker jobmonitor Runs for a Week Then Fails

Summary: NetWorker jobmonitor request runs for a week and then fails. Removing the jobmonitor.db file resolves the issue for a week before the issue is again observed.

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Symptoms

DPA agent is installed directly on NetWorker.
NetWorker jobmonitor runs successfully for seven days and then starts to fail with:
ERR      4502.4978     20231023:223102     com.agent.worker - runAgentWorkerRequest(): Timeout from worker process while running request networker:jobmonitor 
Or:
Unexpected EOF from worker process while running request networker:jobmonitor 
Or:
"The request networker:jobmonitor has failed as there was an error while committing a transaction on the required pstore <path>":
Screenshot of error message

Jobmonitor is the only request that fails. All other requests appear to run successfully.

Removing the jobmonitor.db (<install dir>/dpa/agent/data/) file provides temporary relief until another seven days, when the issue is again observed.

Cause

After eliminating the issue addressed with timeouts, it was observed that the DPA install path was in the anti-virus (AV) software that is running on NetWorker. Apparently when the AV scanner is run, the issue occurs.

Resolution

Remove the full DPA path from scanning on the AV software.

This is outlined in the Administrator Guide where steps to remove the DPA path are outlined.

See: Data Protection Advisor Administration and Installation Guide
Section: Configuring anti-virus software with DPA (Chapter 2)

Affected Products

Data Protection Advisor
Article Properties
Article Number: 000220249
Article Type: Solution
Last Modified: 15 Dec 2023
Version:  2
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