PowerProtect:Oracleバックアップが「ABO0022:内部エラーのため」で失敗する

Summary: PowerProtect Data Manager(PPDM)のOracleバックアップが「ABO0022PowerProtect Data Manager Oracleエージェントは、内部エラーのため、データベースID DBIDのOracleデータベースDBNAMEのバックアップを実行できません。

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Symptoms

中に PPDMの 一元的な保護ポリシーによって開始されるOracleバックアップでは、Oracleデータベースのバックアップが失敗します。Protection Jobsウィンドウに次のエラーが表示されます。

ABO0022: PowerProtect Data Manager Oracle agent cannot perform the backup for the Oracle database db19 with database ID 854318690 because of an internal error.

The backup is unsuccessful because of an SBT error that is caused by the loss of DD connectivity or by an Oracle RMAN error.

Check the DD connectivity from the client. Edit the required protection policy to enable the debug logging. Resubmit the backup request, and check the sbtio.log file under $ORACLE_BASE. Make sure that the database is running during the backup.

RMAN-06149: cannot BACKUP DATABASE in NOARCHIVELOG mode
Recovery Manager complete.

 

Cause

オンラインOracleオンライン バックアップを実行するには、ターゲット データベースがアーカイブログ モードで実行されている必要があります。これはOracleの要件です。PPDMの一元的保護ポリシーは、バックアップ中にデータベースのモードを変更することはできません。つまり、DBをシャットダウンし、マウントを起動してからバックアップを実行することはできません。Oracle dbが開いており、適切なアーカイブ ログ モードの状態であることが期待されます。

 

Resolution

ターゲット データベースがアーカイブ ログ モードであることを確認します。例:

sqlplusを介してターゲット データベースに接続し、archive log listコマンドを発行します。

sqlplus / as sysdba

SQL*Plus: Release 19.0.0.0.0 - Production on Mon Dec 4 22:05:42 2023 Version 19.3.0.0.0 Copyright (c) 1982, 2019, Oracle. All rights reserved.

Connected to: Oracle Database 19c Enterprise Edition Release 19.0.0.0.0 - Production Version 19.3.0.0.0

SQL> archive log list;
Database log mode              No Archive Mode
Automatic archival             Disabled
Archive destination            USE_DB_RECOVERY_FILE_DEST
Oldest online log sequence     16
Current log sequence           18
SQL>

上記の例は、データベースがアーカイブ ログなしモードであることを示しています。

DBAは、データベースをアーカイブログ モードに切り替える必要があります。そのためには、DBをシャットダウンし、適切なモードで起動する必要があります。

 

Article Properties
Article Number: 000220275
Article Type: Solution
Last Modified: 07 Jul 2025
Version:  2
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