NetWorker: »Не вдалося відкрити файл блокування: Permission denied " помилка під час виконання будь-якої команди в nsr
Summary: Неможливо використовувати будь-які утиліти командного рядка NetWorker через проблеми з дозволами.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Команда mminfo завершується помилкою з такою помилкою:
Це також стосується nsrcapinfo,nsradmin, nsrlogin, nsrauthtrust тощо.
136611:mminfo: Failed to open the lock file: Permission denied 144502:nsrd: Unable to set user privileges based on user token for localadmin on <NW-Server-Name>: Failed to validate security token. 167325:mminfo: Unable to connect to media database server on host <NW-Server-Name>: Unable to set user privileges based on user token for localadmin on <NW-Server-Name>: Failed to validate security token.
Це також стосується nsrcapinfo,nsradmin, nsrlogin, nsrauthtrust тощо.
Cause
Файл .administrator.lck не має достатнього дозволу на хост сервера NetWorker.
Resolution
Зміна прав доступу до файлу блокування nsrlogin у /nsr/tmp/sec/tokens
Windows:
- Перейдіть до /nsr/tmp/sec/tokens
- Знайдіть файл ".nsrlogin.localadmin.lck" (Це прихований файл, у Windows натисніть перегляд, потім покажіть прихований).
- Змініть дозвіл на доступ до файлів, щоб локальний адміністратор мав повний контроль.
Linux:
- cd /nsr/tmp/sec/tokens
- Введіть "ls -lat", щоб ви могли перерахувати всі приховані файли та показати права доступу.
- Змініть дозволи на доступ до файлів, щоб мати дозволи на читання, запис і виконання.
Article Properties
Article Number: 000220446
Article Type: Solution
Last Modified: 23 Feb 2024
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.