Connectrix B-Series: License install is fail with an error EndTag not found

Summary: License install is failing for the switch with an error "tmp/license_alc.xml:9:parser error : EndTag: ' formatted licenses require file import." ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Error received on the switch CLI when trying to install the license.
  • The below example is for POD license install failed using XML file.
License fail error showing in command prompt
 
  • Below error received when the XML file is opened in PDF or Microsoft edge Browser.
error received when the XML file is opened in PDF or Microsoft edge Browser
 
 
 

Cause

The license file gets corrupted by Microsoft Unicode ^M characters. This often happens when a file is opened by a Microsoft application such as Word or Notepad or so forth.

Resolution

Log in to a linux server and open license file's contents using the command 'cat -v'.
 

  • The below example shows a corrupt file.
     

Example of corrupt file via command line 

'^M' character is added at the end of each line. This is the Unicode code for 'carriage return or line feed' and is often ignored by Microsoft applications but not ignored by UNIX.
 

  • Below is the file where '^M' character are removed and its been cleaned up.
     
Example of '^M' character are removed and its been cleaned up via command line output

These ^M characters affect the integrity of the license and when an attempt is made to import the license file these effectively corrupt the XML code and this is why the import fails.

 
 
 
 

Affected Products

Connectrix B-Series

Products

Connectrix B-Series Fabric OS 9.X
Article Properties
Article Number: 000221175
Article Type: Solution
Last Modified: 29 Jan 2024
Version:  1
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