Interfejs internetowy narzędzia OpenManage Server Administrator nie ładuje się na serwerach, gdy nazwa hosta ma znak podkreślenia
Summary: Instrukcje przywracania dostępu do interfejsu internetowego narzędzia OpenManage Server Administrator (OMSA) na serwerze ze ze znakiem podkreślenia w nazwie hosta
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Interfejs internetowy narzędzia OpenManage Server Administrator (OMSA) jest niedostępny na serwerze, na którym nazwa hosta zawiera znak podkreślenia. Na przykład nazwa hosta serwera to "FS_1.domena.lokalna". Otrzymana wiadomość to zwykle "This site can't be reached" or "ERR_CONNECTION_CLOSED”. Usługa DSM SA Connection Service jest uruchomiona i nasłuchuje połączeń na porcie 1311 zgodnie z oczekiwaniami.
Cause
Podkreślenia nie są prawidłowym znakiem nazw hostów DNS (Domain Name System), zgodnie z dokumentacją RFC 1912.
https://datatracker.ietf.org/doc/html/rfc1912#section-2.1W rezultacie narzędzie OMSA nie może wygenerować certyfikatu z podpisem własnym podczas instalacji i uruchamia swoje usługi bez prawidłowej konfiguracji TLS. Usługa połączenia nadal działa i wiąże się z portem 1311 podczas uruchamiania, ale nie akceptuje połączeń.
https://datatracker.ietf.org/doc/html/rfc1912#section-2.1W rezultacie narzędzie OMSA nie może wygenerować certyfikatu z podpisem własnym podczas instalacji i uruchamia swoje usługi bez prawidłowej konfiguracji TLS. Usługa połączenia nadal działa i wiąże się z portem 1311 podczas uruchamiania, ale nie akceptuje połączeń.
Resolution
Opcja A
Zmień nazwę serwera na nową, która zawiera tylko litery, cyfry lub łączniki, a następnie odinstaluj i ponownie zainstaluj narzędzie OMSA.
Opcja B
Zainstaluj prawidłowy certyfikat i uzyskaj dostęp do narzędzia OMSA za pomocą adresu IP, a nie nazwy hosta. Uruchomienie następującego polecenia OMConfig na serwerze, którego dotyczy problem, spowoduje utworzenie nowego certyfikatu z podpisem własnym:
Zastąp "<servername>" dowolną obsługiwaną wartością. Najprostszą opcją jest użycie bieżącej nazwy serwera z usuniętymi podkreśleniami.
Zmień nazwę serwera na nową, która zawiera tylko litery, cyfry lub łączniki, a następnie odinstaluj i ponownie zainstaluj narzędzie OMSA.
Opcja B
Zainstaluj prawidłowy certyfikat i uzyskaj dostęp do narzędzia OMSA za pomocą adresu IP, a nie nazwy hosta. Uruchomienie następującego polecenia OMConfig na serwerze, którego dotyczy problem, spowoduje utworzenie nowego certyfikatu z podpisem własnym:
omconfig preferences webserver attribute=gennewcert cn=<servername> org=Dell ou=ESG location=RoundRock state=TX country=US validity=3650 keysize=2048 algorithm=SHA512 webserverrestart=true
Zastąp "<servername>" dowolną obsługiwaną wartością. Najprostszą opcją jest użycie bieżącej nazwy serwera z usuniętymi podkreśleniami.
Affected Products
OpenManage Server AdministratorArticle Properties
Article Number: 000221443
Article Type: Solution
Last Modified: 10 Apr 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.