PowerProtect: El navegador de informes de Data Manager no puede enviar un informe por correo electrónico mediante el servidor SMTP con StartTLS habilitado.

Summary: Los usuarios no reciben informes por correo electrónico.

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Symptoms

Después de agregar la configuración de configuración de correo electrónico a PowerProtect Data Manager (PPDM), los informes no se reciben a través de mensajes de correo electrónico.

En el servidor de informes, hay un error similar al siguiente en el archivo server.log:
2024-02-05 15:32:37,010 ERROR [com.emc.dpa.command.notification.NotificationSenderMDB] (Thread-131073) Problems while sending e-mail notification: com.sun.mail.smtp.SMTPSendFailedException: 451 5.7.3 STARTTLS is required to send mail [MailServer 2024-02-05T08:32:36.994Z 08DC257F199B3AC5]
 

Cause

El servidor de correo electrónico definido en la configuración tiene StartTLS habilitado. Requiere que los clientes utilicen StartTLS mientras se conectan para enviar mensajes de correo electrónico.

Resolution

Para resolver este problema, StartTLS debe estar habilitado dentro de la configuración almacenada en el servidor de generación de informes.

Se pueden seguir los pasos que se mencionan a continuación para resolver el problema.

Pasos para PowerProtect Data Manager 19.16

  1. Inicie sesión en el servidor de generación de informes con una cuenta de administrador y, a continuación, cambie a raíz. En caso de que necesite credenciales, comuníquese con el equipo de soporte técnico de Dell Technologies para obtener ayuda con las credenciales.
  2. Cambie el directorio remoto a '/opt/emc/dpa/services/bin' carpeta. 
# cd /opt/emc/dpa/services/bin
 
  1. Ejecute el siguiente comando para obtener detalles de la configuración actual:
# ./dpa.sh ds query "select * from apollo.mail_server_configuration"

  
  1. Anote el valor informado en f_id y f_start_tls_enabled. El siguiente es un ejemplo del resultado esperado:
# ./dpa.sh ds query "select * from apollo.mail_server_configuration"
EMC Data Protection Advisor
                 f_id                 |     f_lastmodified      |           f_credential_id            |  f_from_address   |     f_hostname     | f_port | f_security_protocol | f_start_tls_enabled
--------------------------------------+-------------------------+--------------------------------------+-------------------+--------------------+--------+---------------------+---------------------
 d61193eb-be0c-42aa-a841-7ef1b281d008 | 2023-12-12 09:02:01.978 | c7321673-3879-4c5e-b0f2-a0029f8815c9 | ppdm@yourcompany.com | smtp.emailserverdomain.com |    587 | None                | f
(1 row)
 
  1. Si la solicitud en f_start_tls_enabled El valor se establece en "F", se debe cambiar a "T". Para realizar este cambio, se puede utilizar el siguiente comando:
./dpa.sh ds query "UPDATE apollo.mail_server_configuration SET  f_start_tls_enabled = 't' WHERE f_id = 'f_id identified from step above'"

  
Ejemplo:
# ./dpa.sh ds query "UPDATE apollo.mail_server_configuration SET  f_start_tls_enabled = 't' WHERE f_id = 'd61193eb-be0c-42aa-a841-7ef1b281d008'"

EMC Data Protection Advisor

UPDATE 1
 
  1. Reinicie los servicios en el servidor de generación de informes mediante el siguiente comando:
# ./dpa.sh svc restart 
 

Pasos para PowerProtect Data Manager 19.17

  1. Inicie sesión en el servidor de generación de informes con una cuenta de administrador y, a continuación, cambie a raíz. En caso de que necesite credenciales, comuníquese con el equipo de soporte técnico de Dell Technologies para obtener ayuda con las credenciales.

    Nota: En algunos pasos diferentes, la contraseña se menciona como 'Password123!'. Eso se debe actualizar con una contraseña real.
     
  2. Ejecute el siguiente comando para obtener detalles de la configuración actual:
# psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/apollo -c "select * from apollo.mail_server_configuration" 
 
  1. Anote el valor informado en f_id y f_start_tls_enabled. El siguiente es un ejemplo del resultado esperado:
# psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/apollo -c "select * from apollo.mail_server_configuration"    
EMC Data Protection Advisor                     
f_id                 |     f_lastmodified      |           f_credential_id            |  f_from_address   |     f_hostname     | f_port | f_security_protocol | f_start_tls_enabled    
--------------------------------------+-------------------------+--------------------------------------+-------------------+--------------------+--------+---------------------+---------------------     
d61193eb-be0c-42aa-a841-7ef1b281d008 | 2023-12-12 09:02:01.978 | c7321673-3879-4c5e-b0f2-a0029f8815c9 | ppdm@yourcompany.com | smtp.emailserverdomain.com |    587 | None                | f    
(1 row)   

  

 

  1. Si la solicitud en f_start_tls_enabled El valor se establece en "F", se debe cambiar a "T". Para realizar este cambio, se puede utilizar el siguiente comando:
#psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/apollo -c "UPDATE apollo.mail_server_configuration SET f_start_tls_enabled = 't' WHERE f_id = 'f_id identified from step above'" 
 
Ejemplo:
# psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/apollo -c "UPDATE apollo.mail_server_configuration SET  f_start_tls_enabled = 't' WHERE f_id = 'd61193eb-be0c-42aa-a841-7ef1b281d008'"  
 
EMC Data Protection Advisor  
 
UPDATE 1 
 
  1. Reinicie los servicios en el servidor de generación de informes mediante el siguiente comando:
# systemctl start reporting-service.service reporting-data-collector.service  reporting-data-processor.service reporting-generator.service 

 

Pasos para PowerProtect Data Manager 19.18

  1. Inicie sesión en el servidor de generación de informes con una cuenta de administrador y, a continuación, cambie a raíz. En caso de que necesite credenciales, comuníquese con el equipo de soporte técnico de Dell Technologies para obtener ayuda con las credenciales.

    Nota: En algunos pasos diferentes, la contraseña se menciona como 'Password123!'. Eso se debe actualizar con una contraseña real.
     
  2. Ejecute el siguiente comando para obtener detalles de la configuración actual:
 
# psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/reporting -c "select * from reportconfig.mail_server_configuration" 
 
  1. Anote el valor informado en f_id y f_start_tls_enabled. El siguiente es un ejemplo del resultado esperado:
EMC Data Protection Advisor
                     f_id                 |     f_lastmodified      |           f_credential_id            |  f_from_address   |     f_hostname     | f_port | f_security_protocol | f_start_tls_enabled    
--------------------------------------+-------------------------+--------------------------------------+-------------------+--------------------+--------+---------------------+---------------------     
d61193eb-be0c-42aa-a841-7ef1b281d008 | 2023-12-12 09:02:01.978 | c7321673-3879-4c5e-b0f2-a0029f8815c9 | ppdm@yourcompany.com | smtp.emailserverdomain.com |    587 | None                | f    
(1 row)    
 
  1. Si la solicitud en f_start_tls_enabled El valor se establece en "F", se debe cambiar a "T". Para realizar este cambio, se puede utilizar el siguiente comando:
psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/reporting -c "UPDATE reportconfig.mail_server_configuration SET  f_start_tls_enabled = 't' WHERE f_id = 'f_id identified from step above'"   
 
Ejemplo:
# psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/reporting -c "UPDATE reportconfig.mail_server_configuration SET  f_start_tls_enabled = 't' WHERE f_id = 'd61193eb-be0c-42aa-a841-7ef1b281d008'"  

EMC Data Protection Advisor  
 
UPDATE 1 
 
  1. Reinicie los servicios en el servidor de generación de informes mediante el siguiente comando:
# systemctl start reporting-service.service reporting-data-collector.service  reporting-data-processor.service reporting-generator.service 

Affected Products

PowerProtect Data Manager, PowerProtect Data Manager Essentials
Article Properties
Article Number: 000221887
Article Type: Solution
Last Modified: 26 May 2025
Version:  3
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