PowerProtect: Data Manager-rapportbrowser kan geen e-mailrapport verzenden via SMTP-server waarop StartTLS is ingeschakeld.

Summary: E-mailrapporten worden niet ontvangen door de gebruikers.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Na het toevoegen van de configuratie van e-mailinstellingen aan PowerProtect Data Manager (PPDM) worden er geen rapporten meer ontvangen via e-mailberichten.

Op de rapportageserver is een fout vergelijkbaar met de volgende aanwezig in het server.log-bestand:
2024-02-05 15:32:37,010 ERROR [com.emc.dpa.command.notification.NotificationSenderMDB] (Thread-131073) Problems while sending e-mail notification: com.sun.mail.smtp.SMTPSendFailedException: 451 5.7.3 STARTTLS is required to send mail [MailServer 2024-02-05T08:32:36.994Z 08DC257F199B3AC5]
 

Cause

Voor de e-mailserver die is gedefinieerd in de configuratie is StartTLS ingeschakeld. Het vereist dat clients StartTLS gebruiken terwijl ze verbinding maken om e-mailberichten te verzenden.

Resolution

U kunt dit probleem oplossen door StartTLS in te schakelen binnen de configuratie die is opgeslagen op de rapportageserver.

Onderstaande stappen kunnen worden gevolgd om het probleem op te lossen.

Stappen voor PowerProtect Data Manager 19.16

  1. Meld u aan bij de rapportageserver met een beheerdersaccount en schakel vervolgens over naar root. Als er aanmeldgegevens nodig zijn, neemt u contact op met het technische supportteam van DELL Technologies om u te helpen met de aanmeldgegevens.
  2. Verander de directory in '/opt/emc/dpa/services/bin' map. 
# cd /opt/emc/dpa/services/bin
 
  1. Voer de volgende opdracht uit om details van de huidige configuratie op te halen:
# ./dpa.sh ds query "select * from apollo.mail_server_configuration"

  
  1. Notering van de waarde gerapporteerd onder f_id als f_start_tls_enabled. Hieronder volgt een voorbeeld van het verwachte resultaat:
# ./dpa.sh ds query "select * from apollo.mail_server_configuration"
EMC Data Protection Advisor
                 f_id                 |     f_lastmodified      |           f_credential_id            |  f_from_address   |     f_hostname     | f_port | f_security_protocol | f_start_tls_enabled
--------------------------------------+-------------------------+--------------------------------------+-------------------+--------------------+--------+---------------------+---------------------
 d61193eb-be0c-42aa-a841-7ef1b281d008 | 2023-12-12 09:02:01.978 | c7321673-3879-4c5e-b0f2-a0029f8815c9 | ppdm@yourcompany.com | smtp.emailserverdomain.com |    587 | None                | f
(1 row)
 
  1. Als de f_start_tls_enabled Waarde is ingesteld op "F", moet deze worden gewijzigd in "T". Om deze wijziging aan te brengen, kan de volgende opdracht worden gebruikt:
./dpa.sh ds query "UPDATE apollo.mail_server_configuration SET  f_start_tls_enabled = 't' WHERE f_id = 'f_id identified from step above'"

  
Voorbeeld:
# ./dpa.sh ds query "UPDATE apollo.mail_server_configuration SET  f_start_tls_enabled = 't' WHERE f_id = 'd61193eb-be0c-42aa-a841-7ef1b281d008'"

EMC Data Protection Advisor

UPDATE 1
 
  1. Start de services op de rapporterende server opnieuw met behulp van de onderstaande opdracht:
# ./dpa.sh svc restart 
 

Stappen voor PowerProtect Data Manager 19.17

  1. Meld u aan bij de rapportageserver met een beheerdersaccount en schakel vervolgens over naar root. Als er aanmeldgegevens nodig zijn, neemt u contact op met het technische supportteam van DELL Technologies om u te helpen met de aanmeldgegevens.

    Notitie: Bij een paar verschillende stappen wordt het wachtwoord vermeld als 'Wachtwoord123!'. Dat moet worden bijgewerkt met een echt wachtwoord.
     
  2. Voer de volgende opdracht uit om details van de huidige configuratie op te halen:
# psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/apollo -c "select * from apollo.mail_server_configuration" 
 
  1. Notering van de waarde gerapporteerd onder f_id als f_start_tls_enabled. Hieronder volgt een voorbeeld van het verwachte resultaat:
# psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/apollo -c "select * from apollo.mail_server_configuration"    
EMC Data Protection Advisor                     
f_id                 |     f_lastmodified      |           f_credential_id            |  f_from_address   |     f_hostname     | f_port | f_security_protocol | f_start_tls_enabled    
--------------------------------------+-------------------------+--------------------------------------+-------------------+--------------------+--------+---------------------+---------------------     
d61193eb-be0c-42aa-a841-7ef1b281d008 | 2023-12-12 09:02:01.978 | c7321673-3879-4c5e-b0f2-a0029f8815c9 | ppdm@yourcompany.com | smtp.emailserverdomain.com |    587 | None                | f    
(1 row)   

  

 

  1. Als de f_start_tls_enabled Waarde is ingesteld op "F", moet deze worden gewijzigd in "T". Om deze wijziging aan te brengen kan de volgende opdracht worden gebruikt:
#psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/apollo -c "UPDATE apollo.mail_server_configuration SET f_start_tls_enabled = 't' WHERE f_id = 'f_id identified from step above'" 
 
Voorbeeld:
# psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/apollo -c "UPDATE apollo.mail_server_configuration SET  f_start_tls_enabled = 't' WHERE f_id = 'd61193eb-be0c-42aa-a841-7ef1b281d008'"  
 
EMC Data Protection Advisor  
 
UPDATE 1 
 
  1. Start de services op de rapporterende server opnieuw met behulp van de onderstaande opdracht:
# systemctl start reporting-service.service reporting-data-collector.service  reporting-data-processor.service reporting-generator.service 

 

Stappen voor PowerProtect Data Manager 19.18

  1. Meld u aan bij de rapportageserver met een beheerdersaccount en schakel vervolgens over naar root. Als er aanmeldgegevens nodig zijn, neemt u contact op met het technische supportteam van DELL Technologies om u te helpen met de aanmeldgegevens.

    Notitie: In een paar verschillende stappen wordt het wachtwoord vermeld als 'Wachtwoord123!'. Dat moet worden bijgewerkt met een echt wachtwoord.
     
  2. Voer de volgende opdracht uit om details van de huidige configuratie op te halen:
 
# psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/reporting -c "select * from reportconfig.mail_server_configuration" 
 
  1. Notering van de waarde gerapporteerd onder f_id als f_start_tls_enabled. Hieronder volgt een voorbeeld van het verwachte resultaat:
EMC Data Protection Advisor
                     f_id                 |     f_lastmodified      |           f_credential_id            |  f_from_address   |     f_hostname     | f_port | f_security_protocol | f_start_tls_enabled    
--------------------------------------+-------------------------+--------------------------------------+-------------------+--------------------+--------+---------------------+---------------------     
d61193eb-be0c-42aa-a841-7ef1b281d008 | 2023-12-12 09:02:01.978 | c7321673-3879-4c5e-b0f2-a0029f8815c9 | ppdm@yourcompany.com | smtp.emailserverdomain.com |    587 | None                | f    
(1 row)    
 
  1. Als de f_start_tls_enabled Waarde is ingesteld op "F", moet deze worden gewijzigd in "T". Om deze wijziging aan te brengen kan de volgende opdracht worden gebruikt:
psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/reporting -c "UPDATE reportconfig.mail_server_configuration SET  f_start_tls_enabled = 't' WHERE f_id = 'f_id identified from step above'"   
 
Voorbeeld:
# psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/reporting -c "UPDATE reportconfig.mail_server_configuration SET  f_start_tls_enabled = 't' WHERE f_id = 'd61193eb-be0c-42aa-a841-7ef1b281d008'"  

EMC Data Protection Advisor  
 
UPDATE 1 
 
  1. Start de services op de rapporterende server opnieuw met behulp van de onderstaande opdracht:
# systemctl start reporting-service.service reporting-data-collector.service  reporting-data-processor.service reporting-generator.service 

Affected Products

PowerProtect Data Manager, PowerProtect Data Manager Essentials
Article Properties
Article Number: 000221887
Article Type: Solution
Last Modified: 26 May 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.