NetWorker Client CLI backup gets incorrect retention time applied

Summary: When a command-line save is initiated from the client and when the client has a resource created on the server and is not associated to any policy, then the default browse and retention time are set to 11:11:11 AM, 29th Feb, 2152 (GMT). This was due to the first instance of the client definition not having a policy assigned, and it gets the default 2152 year retention applied. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

A NetWorker client has backups with a save set retention of 11:11:11 AM, 29th Feb, 2152 (GMT).

mminfo -q client=client_name -r client,name,savetime,ssid,ssretent,level

Example:

root@lnx-nwserv:~# mminfo -q client=win-client01.amer.lan -r client,name,savetime,ssid,ssretent,level
 client    name                             date   ssid        retent    lvl
win-client01.amer.lan E:\somefile1.txt   02/27/2024 2631813516 02/29/2152 manual
The backup is performed manually by initiating the save command on the client.

Cause

There are multiple NetWorker client resources configured for this same host. The first NetWorker client instance in the nsrdb is not assigned to a protection group or policy:

On the NetWorker server:

nsradmin
show protection group list; name
p type: nsr client; name: client_name

Example:

root@lnx-nwserv:~# nsradmin
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> show protection group list; name
nsradmin> p type: nsr client; name: win-client01.amer.lan
                        name: win-client01.amer.lan;
       protection group list: ;

                        name: win-client01.amer.lan;
       protection group list: Filesystem-Windows;
nsradmin> q


This is by design, as per ENG ESC NWREE-25583.

Resolution

Ensure all instances of a NetWorker client have a policy assigned.
Article Properties
Article Number: 000222284
Article Type: Solution
Last Modified: 27 Feb 2024
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.