DPA zeigt die Admin-Benutzeroberfläche des Anwendungsservers nach dem Upgrade auf IDPA 2.7.6 in ACM als rot an
Summary: In diesem Artikel wird beschrieben, wie Sie ein Problem mit Reporting und Analysen in Data Protection Advisor (DPA) nach dem Upgrade auf IDPA-Version 2.7.6 beheben.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Nach dem Upgrade auf IDPA 2.7.6 wird Reporting and Analytics (DPA) in der ACM-Benutzeroberfläche rot angezeigt.
Im ACM-server.log wird einer der beiden folgenden Fehler angezeigt:
2024-02-09 10:42:54,841 INFO [Thread-25170]-util.RestUtil: Making REST call: https://x.x.x.x:9002/dpa-api/license ,method: GET Meditype application/v nd.emc.apollo-v1+xml 2024-02-09 10:42:54,882 INFO [Thread-25170]-util.RestUtil: REST request return code: 500, expected code: OK
2024-02-13 19:58:25,577 INFO [Thread-93984]-util.RestUtil: Making REST call: https://x.x.x.x:9002/dpa-api/license ,method: GET Meditype application/vnd.emc.apollo-v1+xml ... 2024-02-13 19:58:25,601 INFO [Timer-4]-dao.HealthMonitorUtilityDao: getDeviceDataByType --> Executing query to get device by type and ip 2024-02-13 19:58:25,602 INFO [Thread-93984]-util.RestUtil: REST request return code: 404, expected code: OK
In der DPA-APP-server.log werden Fehler wie die folgenden angezeigt:
16224:2024-02-09 14:24:20,299 ERROR [org.jboss.msc.service.fail] (ServerService Thread Pool -- 62) MSC000001: Failed to start service jboss.web.deployment.default-host./reportengine-api: org.jboss.msc.service.StartException in service jboss.web.deployment.default-host./reportengine-api: org.jboss.msc.service.StartException in anonymous service: JBAS018040: Failed to start context 16238:2024-02-09 14:24:20,318 ERROR [org.apache.catalina.core] (ServerService Thread Pool -- 72) JBWEB001100: Error starting context: java.lang.IllegalArgumentException: JBWEB006706: Document base /opt/emc/dpa/services/./standalone/tmp/vfs/deployment/deploymentd28786588379a29/listener-processor-war.war-37c80da349d9164f does not exist or is not a readable directory 16252:2024-02-09 14:24:20,338 ERROR [org.apache.catalina.core] (ServerService Thread Pool -- 72) JBWEB001103: Error detected during context /listener-processor-api start, will stop it 16253:2024-02-09 14:24:20,339 ERROR [org.jboss.msc.service.fail] (ServerService Thread Pool -- 72) MSC000001: Failed to start service jboss.web.deployment.default-host./listener-processor-api: org.jboss.msc.service.StartException in service jboss.web.deployment.default-host./listener-processor-api: org.jboss.msc.service.StartException in anonymous service: JBAS018040: Failed to start context 16296:2024-02-09 14:24:21,337 ERROR [org.jboss.as] (Controller Boot Thread) JBAS015875: JBoss AS 7.4.1.Final-redhat-SNAPSHOT "Janus" started (with errors) in 41681ms - Started 21215 of 21353 services (58 services failed or missing dependencies, 315 services are lazy, passive or on-demand)
Cause
DPA verfügt über Prozesse in der
/opt/emc/dpa/services/./standalone Unterverzeichnisse, die dafür sorgen, dass die APP-Dienste ordnungsgemäß funktionieren. DPA zeigt Services an, die ausgeführt werden, aber einige interne Services sind ausgefallen.Resolution
Führen Sie das folgende Verfahren aus, um dieses Problem zu beheben:
- Beenden Sie die DPA-Services mit dem folgenden Befehl. Führen Sie diesen Befehl zuerst auf dem DPA-DS-Server und dann auf dem DPA-APP-Server aus.
dpa.sh svc stop
- Melden Sie sich mit SSH oder PuTTY als Root beim DPA APP-Server an und führen Sie den folgenden Befehl aus:
rm -rf /opt/emc/dpa/services/standalone/data rm -rf /opt/emc/dpa/services/standalone/tmp
- Starten Sie den DPADS-Server neu und starten Sie die Services:
reboot dpa.sh svc start
- Starten Sie den DPA APP-Server neu und starten Sie die Services.
reboot dpa.sh svc start
- Vergewissern Sie sich, dass Sie sich bei der DPA-Benutzeroberfläche anmelden können.
- Vergewissern Sie sich, dass DPA in der ACM-Benutzeroberfläche grün angezeigt wird.
Article Properties
Article Number: 000222530
Article Type: Solution
Last Modified: 26 Mar 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.