DPA affiche l’interface utilisateur d’administration du serveur d’applications en rouge dans ACM après la mise à niveau vers IDPA 2.7.6

Summary: Cet article explique comment résoudre un problème lié à la création de rapports et à l’analytique dans Data Protection Advisor (DPA) après la mise à niveau vers IDPA version 2.7.6.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Après la mise à niveau vers IDPA 2.7.6, Reporting et analytique (DPA) s’affiche en rouge dans l’interface utilisateur d’ACM.

Dans le server.log ACM, l’une des deux erreurs suivantes s’affiche :

2024-02-09 10:42:54,841 INFO  [Thread-25170]-util.RestUtil: Making REST call: https://x.x.x.x:9002/dpa-api/license ,method: GET Meditype application/v
nd.emc.apollo-v1+xml
2024-02-09 10:42:54,882 INFO  [Thread-25170]-util.RestUtil:  REST request return code: 500, expected code: OK
2024-02-13 19:58:25,577 INFO  [Thread-93984]-util.RestUtil: Making REST call: https://x.x.x.x:9002/dpa-api/license ,method: GET Meditype application/vnd.emc.apollo-v1+xml
...
2024-02-13 19:58:25,601 INFO  [Timer-4]-dao.HealthMonitorUtilityDao: getDeviceDataByType --> Executing query to get device by type and ip
2024-02-13 19:58:25,602 INFO  [Thread-93984]-util.RestUtil:  REST request return code: 404, expected code: OK

Dans DPA APP server.log, des erreurs semblables à celles suivantes s’affichent :

16224:2024-02-09 14:24:20,299 ERROR [org.jboss.msc.service.fail] (ServerService Thread Pool -- 62) MSC000001: Failed to start service jboss.web.deployment.default-host./reportengine-api: org.jboss.msc.service.StartException in service jboss.web.deployment.default-host./reportengine-api: org.jboss.msc.service.StartException in anonymous service: JBAS018040: Failed to start context
16238:2024-02-09 14:24:20,318 ERROR [org.apache.catalina.core] (ServerService Thread Pool -- 72) JBWEB001100: Error starting context: java.lang.IllegalArgumentException: JBWEB006706: Document base /opt/emc/dpa/services/./standalone/tmp/vfs/deployment/deploymentd28786588379a29/listener-processor-war.war-37c80da349d9164f does not exist or is not a readable directory
16252:2024-02-09 14:24:20,338 ERROR [org.apache.catalina.core] (ServerService Thread Pool -- 72) JBWEB001103: Error detected during context /listener-processor-api start, will stop it
16253:2024-02-09 14:24:20,339 ERROR [org.jboss.msc.service.fail] (ServerService Thread Pool -- 72) MSC000001: Failed to start service jboss.web.deployment.default-host./listener-processor-api: org.jboss.msc.service.StartException in service jboss.web.deployment.default-host./listener-processor-api: org.jboss.msc.service.StartException in anonymous service: JBAS018040: Failed to start context
16296:2024-02-09 14:24:21,337 ERROR [org.jboss.as] (Controller Boot Thread) JBAS015875: JBoss AS 7.4.1.Final-redhat-SNAPSHOT "Janus" started (with errors) in 41681ms - Started 21215 of 21353 services (58 services failed or missing dependencies, 315 services are lazy, passive or on-demand)

Cause

DPA dispose de processus dans le /opt/emc/dpa/services/./standalone sous-répertoires à l’origine du bon fonctionnement des services APP. DPA montre que les services sont en cours d’exécution, mais que certains services internes ont échoué.

Resolution

Pour résoudre ce problème, exécutez la procédure suivante :
  1. Arrêtez les services DPA à l’aide de la commande suivante. Exécutez d’abord cette commande sur le serveur DPA DS, puis sur le serveur DPA APP. 
dpa.sh svc stop
  1. Connectez-vous au serveur DPA APP en tant qu’utilisateur root à l’aide de SSH ou PuTTY et exécutez la commande suivante :
rm -rf /opt/emc/dpa/services/standalone/data
rm -rf /opt/emc/dpa/services/standalone/tmp
  1. Redémarrez le serveur DPA DS et démarrez les services :
reboot
dpa.sh svc start
  1. Redémarrez le serveur DPA APP et démarrez les services. 
reboot
dpa.sh svc start
  1. Vérifiez que vous pouvez vous connecter à l’interface utilisateur DPA.
  2. Vérifiez que DPA s’affiche en vert dans l’interface utilisateur d’ACM. 
Article Properties
Article Number: 000222530
Article Type: Solution
Last Modified: 26 Mar 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.