O DPA mostra a interface do usuário de administração do servidor de aplicativos como vermelha no ACM após o upgrade para o IDPA 2.7.6
Summary: Este artigo aborda como corrigir um problema com geração de relatórios e lógica analítica no Data Protection Advisor (DPA) após o upgrade para o IDPA versão 2.7.6.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Após o upgrade para o IDPA 2.7.6, o relatório e a lógica analítica (DPA) aparecem em vermelho na interface do usuário do ACM.
No server.log do ACM, é exibido um dos dois erros a seguir:
2024-02-09 10:42:54,841 INFO [Thread-25170]-util.RestUtil: Making REST call: https://x.x.x.x:9002/dpa-api/license ,method: GET Meditype application/v nd.emc.apollo-v1+xml 2024-02-09 10:42:54,882 INFO [Thread-25170]-util.RestUtil: REST request return code: 500, expected code: OK
2024-02-13 19:58:25,577 INFO [Thread-93984]-util.RestUtil: Making REST call: https://x.x.x.x:9002/dpa-api/license ,method: GET Meditype application/vnd.emc.apollo-v1+xml ... 2024-02-13 19:58:25,601 INFO [Timer-4]-dao.HealthMonitorUtilityDao: getDeviceDataByType --> Executing query to get device by type and ip 2024-02-13 19:58:25,602 INFO [Thread-93984]-util.RestUtil: REST request return code: 404, expected code: OK
No server.log APP do DPA, erros como os seguintes são exibidos:
16224:2024-02-09 14:24:20,299 ERROR [org.jboss.msc.service.fail] (ServerService Thread Pool -- 62) MSC000001: Failed to start service jboss.web.deployment.default-host./reportengine-api: org.jboss.msc.service.StartException in service jboss.web.deployment.default-host./reportengine-api: org.jboss.msc.service.StartException in anonymous service: JBAS018040: Failed to start context 16238:2024-02-09 14:24:20,318 ERROR [org.apache.catalina.core] (ServerService Thread Pool -- 72) JBWEB001100: Error starting context: java.lang.IllegalArgumentException: JBWEB006706: Document base /opt/emc/dpa/services/./standalone/tmp/vfs/deployment/deploymentd28786588379a29/listener-processor-war.war-37c80da349d9164f does not exist or is not a readable directory 16252:2024-02-09 14:24:20,338 ERROR [org.apache.catalina.core] (ServerService Thread Pool -- 72) JBWEB001103: Error detected during context /listener-processor-api start, will stop it 16253:2024-02-09 14:24:20,339 ERROR [org.jboss.msc.service.fail] (ServerService Thread Pool -- 72) MSC000001: Failed to start service jboss.web.deployment.default-host./listener-processor-api: org.jboss.msc.service.StartException in service jboss.web.deployment.default-host./listener-processor-api: org.jboss.msc.service.StartException in anonymous service: JBAS018040: Failed to start context 16296:2024-02-09 14:24:21,337 ERROR [org.jboss.as] (Controller Boot Thread) JBAS015875: JBoss AS 7.4.1.Final-redhat-SNAPSHOT "Janus" started (with errors) in 41681ms - Started 21215 of 21353 services (58 services failed or missing dependencies, 315 services are lazy, passive or on-demand)
Cause
O DPA tem processos no
/opt/emc/dpa/services/./standalone subdiretórios que estão fazendo com que os serviços de APP funcionem corretamente. O DPA mostra os serviços em execução, mas alguns serviços internos falharam.Resolution
Execute o procedimento a seguir para resolver esse problema:
- Interrompa os serviços do DPA com o comando a seguir. Execute esse comando primeiro no servidor DPA DS e, em seguida, no servidor APP do DPA.
dpa.sh svc stop
- Faça log-in no servidor APP do DPA como root usando SSH ou PuTTY e execute o seguinte comando:
rm -rf /opt/emc/dpa/services/standalone/data rm -rf /opt/emc/dpa/services/standalone/tmp
- Reinicialize o servidor DS do DPA e inicie os serviços:
reboot dpa.sh svc start
- Reinicialize o servidor APP do DPA e inicie os serviços.
reboot dpa.sh svc start
- Confirme se você pode fazer login na interface do usuário do DPA.
- Confirme se o DPA está verde na interface do usuário do ACM.
Article Properties
Article Number: 000222530
Article Type: Solution
Last Modified: 26 Mar 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.