NetWorker: daemon.raw zgłasza błąd "Błąd podczas inicjowania bibliotek związanych z licencjonowaniem CLP"

Summary: Po uaktualnieniu do wersji 19.9 w systemie Linux plik daemon.raw jest wypełniany poniższym błędem: nsrlmc nsr błąd nsrlmc: Błąd podczas inicjowania bibliotek związanych z licencjonowaniem CLP: Nie można załadować biblioteki "libxmlsec1.so" (libltdl.so.7: Nie można otworzyć pliku obiektu współużytkowanego: Nie ma takiego pliku ani katalogu) ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

/nsr/logs/daemon.log rozmiar stale rośnie wraz z tymi błędami.

nsrlmc NSR error nsrlmc: Error while initializing the CLP licensing related libraries: Unable to load library "libxmlsec1.so" (libltdl.so.7: cannot open shared object file: No such file or directory)

NetWorker: Sposób użycia nsr_render_log.

 

Cause

Ten problem występuje, gdy plik /usr/lib64/libltdl.so.7 jest uszkodzony lub go brakuje.

 

Resolution

Wykonaj poniższe czynności na serwerze NetWorker:

  1. Połącz się z serwerem NetWorker przez SSH i przełącz się do katalogu głównego:

    sudo su -
  2. Użyj polecenia yum, aby uzyskać najnowszą nazwę pakietu libtool-ltdl.

    yum provides \*/libltdl.so.7

    Example:
    Przykładowy ekran polecenia yum

  3. Zainstaluj lub ponownie zainstaluj pakiet libtool-ltdl wygenerowany przez powyższe polecenie:

    yum reinstall <libtool-ltdl-2.>

    W tym miejscu zastąp <libtool-ltdl-2.> z wersją biblioteki libtool wymienioną w pierwszym poleceniu. (Na przykład uruchom go jako: yum reinstall libtool-ltdl-2.4.6-25.el8.x86_64)
    Spowoduje to ponowną instalację uszkodzonych lub brakujących bibliotek.

  4. Upewnij się, że problem został rozwiązany, uruchamiając:

    nsrlic -C

 

Products

NetWorker Family
Article Properties
Article Number: 000222710
Article Type: Solution
Last Modified: 25 Apr 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.