PowerProtect Data Manager: Agent type is set to blank

Summary: The Agent type is set to blank even though assets exist and backups work.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The index_host record does not have any applicationsOfInterest information logged to it.

  "_index" : "ppdmesc5260_host",
        "_type" : "_doc",
        "_id" : "419b7aec-25f4-4e0c-8b23-25be8f5ac012",
        "_score" : 5.957563,
        "_source" : {
          "id" : "419b7aec-25f4-4e0c-8b23-25be8f5ac012",
          "createdAt" : "2023-12-20T23:41:32.078Z",
          "updatedAt" : "2024-01-09T21:52:02.337Z",
          "deletedAt" : null,
          "name" : "xxxxxxxxxxxxxxxxx",

Cause

The root cause for why the Agent type was set to blank is unknown. One possibility is that adm may running out of some type of threads.

Resolution

The following generally fixes this issue:

  1. Restart adm service on PowerProtect Data Manager.
  2. Unregister the client.
  3. Rename C:\Program Files\DPSAPPS\AgentService\dbs\v1\resources.db.
  4. Rename the C:\Program Files\DPSAPPS\AgentService\ssl directory on the client, if it is still there.
  5. Re-register the client
Article Properties
Article Number: 000222767
Article Type: Solution
Last Modified: 13 Mar 2026
Version:  3
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