SQL Server-service (MSSQLSERVER) Kan niet worden gestart

Summary: De Microsoft SQL Server-service (MSSQLSERVER) kan mogelijk niet worden gestart vanwege een beschadigde database. Dit artikel illustreert de procedure voor het oplossen van dit probleem. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

De Microsoft SQL Server-service (MSSQLSERVER) kan niet worden gestart. Fout 7024 (bron: Service Control Manager) wordt weergegeven in het systeemgebeurtenislogboek van de server waarop SQL is geïnstalleerd.

Cause

Deze service kan om meerdere redenen niet worden gestart, en dit artikel behandelt er één: een beschadigde database.

Resolution

Wanneer een service niet wordt gestart, registreert de Service Control Manager een fout in het systeemgebeurtenislogboek van de server die als host voor die service fungeert. Deze gebeurtenis (in dit geval ID 7024) biedt mogelijk onvoldoende details om het probleem op te lossen. Bij het oplossen van een probleem met de SQL Server-service bevat het SQL-foutenlogboek waarschijnlijk meer nuttige informatie.

Volg deze stappen om het SQL-foutenlogboek te vinden:
  1. Start SQL Server Configuration Manager.
  2. Selecteer SQL Server Services in het linkerdeelvenster.
  3. Klik in het middelste deelvenster met de rechtermuisknop op SQL Server (MSSQLSERVER) en selecteer Eigenschappen.
  4. Selecteer in het venster Eigenschappen het tabblad Opstartparameters .
  5. In het veld Bestaande parameters bevat de vermelding die begint met -e het pad naar het foutenlogboek.
Blader in Verkenner naar het hierboven beschreven pad. Het ERRORLOG-bestand zonder extensie is het huidige foutenlogbestand. (ERRORLOG-bestanden met numerieke extensies zijn oudere logbestanden.) Open het huidige logbestand in Kladblok en scrol naar het einde van het bestand. De laatste vermelding in het logboek moet een fout zijn die de reden voor de servicefout aangeeft.

Een beschadigde database kan worden aangegeven door een fout die lijkt op deze:

SQL Server heeft een op logische consistentie gebaseerde I/O-fout gedetecteerd: Onjuiste checksum

De foutmelding geeft ook aan in welke database het probleem is voorgekomen. Er zijn drie systeemdatabases vereist voor het starten van SQL-services: de hoofddatabase, de modeldatabase en tempdb. De fout vermeldt hoogstwaarschijnlijk een van deze databases.

Als beschadiging in de hoofddatabase de oorzaak is, is het herstellen van die database vanaf een back-up de aanbevolen oplossing.

Als beschadiging in de modeldatabase de oorzaak is, kan een reparatieprocedure worden gevonden in SQL Server Model Database Repair.

Telkens wanneer de SQL Server-service wordt gestart, wordt de tempdb-database opnieuw gemaakt, zolang de modeldatabase intact is.

Affected Products

Prosupport for Microsoft Software
Article Properties
Article Number: 000223030
Article Type: Solution
Last Modified: 23 Jan 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.