Data Domain:在 DDOS 升级后 iDRAC Web 用户界面不可用 — 与 FQDN 的连接失败

Summary: 在将 DD OS 升级到版本 7.10.1.15、7.10.1.20、7.11.0.0 和 7.13.0.0 后,我们将迁移到 iDRAC 版本 6.x.x。iDRAC 用户界面可能不再可访问,并且需要重新配置。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

iDRAC Web 用户界面可能无法在网页浏览器中加载。
它会报告连接问题,例如“无法连接”、“内部服务器错误”或“400 错误请求”错误。

Cause

“主机标头检查”安全功能可确保使用 IPv4/IPv6 地址、RAC 名称或定义的 FQDN (DNSRacName.DNSDomainName) 访问 iDRAC。

将 iDRAC 固件更新到版本 6.xx 或更高版本会更改静态 1Pv4 或 1Pv6 DNS 设置。
iDRAC 用户界面可能无法再访问;阻止通过 FQDN 对 iDRAC9 固件中的 Web 服务器进行 HTTPS 访问。

以下参数将更改为默认值:
DNSDomainFromDHCP=Enabled
DNSDomainName=
DNSDomainNameFromDHCP=Enabled

从 iDRAC 发行说明:
https://dl.dell.com/content/manual60830302-idrac9-version-5-10-50-00-release-notes.pdf?language=en-us

iDRAC 固件
1.将 iDRAC 固件更新到版本 6.xx 或更高版本会更改静态 1Pv4 或 1Pv6 DNS 设置。确保在升级完成后重新配置网络设置。

Resolution

使用 RACADM 连接并更正 DNS 设置:

1.如果使用“HostHeaderCheck”,请将其禁用。
    racadm set idrac.webserver.HostHeaderCheck 0

2.登录到 iDRAC 用户界面并重新配置 DNS 设置
iDRAC 设置 -> 连接选项卡 -> 网络 -> 通用设置 + 1Pv4 设置/1Pv6 设置

iDRAC设置


iDRAC 设置(屏幕 2)

进行更改后,如果需要重新启用检查,请启用“HostHeaderCheck”。

   racadm set idrac.webserver.HostHeaderCheck 1


再次测试对 iDRAC WEB 控制台的访问

Affected Products

Data Domain, iDRAC9 - 6.xx Series
Article Properties
Article Number: 000223272
Article Type: Solution
Last Modified: 24 Jul 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.