Wake-on-LAN Not Working With RJ45 Connection

Summary: Learn about when a Dell computer with a USB-C multifunction DisplayPort (MFDP) cannot wake from hibernate (S4) when connected to a Dell monitor RJ45 port.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The Wake-on-LAN (WOL) from hibernate (S4) does not work when connected to a Dell monitor RJ45 (LAN) port. This may be described as the hibernate (S4) resuming is failing. The computer cannot be woken up using some third-party apps when connecting to a Dell U3425WE using 2 Lane mode or 4 Lane mode.

Affected Monitors:

  • Dell U2724DE
  • Dell U3425WE
  • Dell U3824DW
  • Dell U4924DW

Affected Platforms:

  • Latitude 3440
  • Precision 5680
  • Precision 7780
  • XPS 15 9530
  • Any Dell computer with a USB-C MFDP port

Cause

Windows 11 operating system design limitations cause this issue. The Windows 11 operating system does not support WOL when entering hibernate (S4) mode.

The Windows software trace preprocessor (WPP) log shows that the operating system set the wrong RJ45 setting (WolMagicPacketEnable = 0x0). This controls whether the WOL command works or not. The computer's operating system controls the WolMagicPacketEnable setting, not the monitor.

Resolution

Updating to Realtek USB GBE Ethernet Controller Driver version 1156.17.20.1029, A30 or later on the computer resolves the issue. The updated driver is posted to the affected monitor’s support page. To download and install the driver, reference How to Download and Install Dell Drivers.

Affected Products

Latitude 3440, Precision 5680, Precision 7780, Dell U2724DE, Dell U3425WE, Dell U3824DW, Dell U4924DW, XPS 15 9530
Article Properties
Article Number: 000223411
Article Type: Solution
Last Modified: 19 Apr 2025
Version:  5
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