Connectrix SANnav: "Switch wird nicht gemanagt" auf dem SANnav-Dashboard.

Summary: Der Switchstatus wird im SANnav-Dashboard als "Schlecht" angezeigt, Grund "Switch wird nicht gemanagt".

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Symptoms


Klicken Sie auf den Switch, dessen Status im SANnav-Dashboard als "Schlecht" angezeigt wird.
Klicken Sie dann auf den entsprechenden Schalter und es öffnet sich ein Statusfenster.
Klicken Sie auf "Show details", um die folgende Warnmeldung anzuzeigen:

image.png

Cause

Die Ursache des Problems kann folgende Gründe haben:
1) Wenn es Konflikte bei der Verwendung von SSH-Ports gibt.
2) Wenn die Switch-Zugangsdaten geändert und für den Switch auf SANnav nicht aktualisiert wurden.

Resolution


Schritte zur Lösung:

Schritt 1:
Melden Sie sich bei der SANnav-Server-CLI an und überprüfen Sie den internen SSH-Port unter:
#<install_home>/conf - Eintrag 'dcm.ssh.server.port'bin]
# ./show-sannav-configurations.sh


Falls der SSH-Port #22 vom SANnav-Server gehalten wird, ändern Sie den SSH-Wert für die SANnav-Anwendung von Port #22 in #6022 unter:
#/etc/ssh/sshd_config

Ändern Sie den SSH-Port in 6022, indem Sie ihn auskommentieren:
Port 6022
#AddressFamily any
#ListenAddress 0.0.0.0
#ListenAddress ::

Fügen Sie den Port #6022 zur firewalld:
#firewall-cmd --permanent --add-port=6022/tcp

hinzu Starten Sie firewalld:
#systemctl restart firewalld neu

Schritt 2:
Wenn das Problem weiterhin besteht, führen Sie " hareboot/hafailover" auf dem Switch durch.

Schritt 3:
Der Switch auf dem SANnav-Dashboard zeigt "Schlecht" an.
Aktualisieren Sie die Switch-Zugangsdaten für den entsprechenden Switch auf der Registerkarte "Fabric Discovery".

Klicken Sie in der Navigationsleiste auf SANnav und wählen Sie dann SAN Monitoring > Fabric Discovery aus.
Auf der Seite Erkannte Fabrics werden alle Fabrics angezeigt, die erkannt wurden. Wenn eine Fabric Switches mit falschen Zugangsdaten enthält, zeigt SANnav in der Spalte Status "Authentifizierung fehlgeschlagen" an.

Klicken Sie auf den Fabric-Namen, um die Fabric-Detailseite zu öffnen, auf der die Liste der Switches in der Fabric angezeigt wird.
Bei Switches mit falschen Zugangsdaten wird in der Spalte Discovery Status"Discovered" angezeigt. Authentifizierung fehlgeschlagen. Nicht für SNMP-Traps registriert."

Wählen Sie die Switches mit den falschen Zugangsdaten aus und klicken Sie auf Konfigurieren.
Wenn der Nutzer einen Switch auswählt, wird das Dialogfeld "Configure" mit den aktuellen Werten für diesen Switch ausgefüllt.
Wenn der Nutzer mehrere Switches auswählt, ist das Dialogfeld Configure leer und alle eingegebenen Werte gelten für alle ausgewählten Switches.
image.png
Wenn sich die Zugangsdaten geändert haben, geben Sie die neuen Zugangsdaten für den Switch ein.

Wenn sich die SNMP-Konfiguration geändert hat, wählen Sie Manuelle SNMP-Konfiguration aus und geben Sie die aktualisierten Informationen in das
Dialogfeld ein.

Klicken Sie auf OK.Die

Anmeldeinformationen, die SANnav zur Ermittlung des Switches oder für die SNMP-Konfiguration verwendet, werden geändert.
Als Nächstes muss der Nutzer die Überwachung des Switches aufheben und dann überwachen, damit die Änderung wirksam wird. 
 
Aktualisieren und überprüfen Sie nach der Durchführung der obigen Schritte das SANnav-Dashboard. Der Switchstatus wird als "fehlerfrei" angezeigt
 

Affected Products

Connectrix SANnav
Article Properties
Article Number: 000224735
Article Type: Solution
Last Modified: 03 May 2024
Version:  1
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