SANnav Connectrix: "Lo switch non è gestito" sul dashboard SANnav.

Summary: Lo stato dello switch viene visualizzato come "Poor", motivo "Switch non gestito" sul dashboard di SANnav.

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Symptoms


Cliccare sullo switch il cui stato viene visualizzato come "Poor" nel dashboard SANnav.
Quindi fare clic sul rispettivo switch per aprire una finestra di stato.
Cliccando su "Mostra dettagli" è possibile visualizzare l'avviso riportato di seguito:

image.png

Cause

La causa del problema potrebbe essere dovuta ai motivi seguenti:
1) Se si verificano conflitti sull'utilizzo delle porte SSH.
2) Se le credenziali dello switch sono state modificate e non aggiornate per lo switch su SANnav.

Resolution


Procedura di risoluzione:

Passo 1:
Effettuare l'accesso alla CLI del server SANnav e controllare la porta SSH interna in:
#<install_home>/conf - entry 'dcm.ssh.server.port'bin]
# ./show-sannav-configurations.sh


Nel caso in cui la porta SSH #22 sia conservata dal server SANnav, modificare l SSH per l'applicazione SANnav dalla porta #22 alla porta #6022 in:
#/etc/ssh/sshd_config

Modificare la porta ssh in 6022 rimuovendo il commento:
Porta 6022
#AddressFamily any
#ListenAddress 0.0.0.0
#ListenAddress ::

Aggiungere la porta #6022 al firewalld:
#firewall-cmd --permanent --add-port=6022/tcp

Riavviare firewalld:
#systemctl restart firewalld

Passaggio 2.
Se il problema persiste, procedere ed eseguire un "hareboot/hafailover" sullo switch.

Passaggio 3.
Lo switch sul dashboard SANnav mostra "Poor"
Aggiornare le credenziali dello switch per il rispettivo switch nella scheda "Fabric Discovery".

Cliccare su SANnav nella barra di navigazione, quindi selezionare SAN Monitoring > Fabric Discovery.
La pagina Fabric rilevate mostra tutte le fabric rilevate. Se una fabric contiene switch con credenziali errate, SANnav visualizza "Authentication failed" nella colonna Status .

Cliccare sul nome della fabric per aprire la pagina dei dettagli della fabric, che visualizza l'elenco degli switch nella fabric.
Per gli switch con credenziali errate, la colonna Stato di individuazione indica "Rilevato. Autenticazione non riuscita. Non registrato per trap SNMP."

Selezionare gli switch con credenziali errate e cliccare su Configure.
Se l'utente seleziona uno switch, la finestra di dialogo Configure viene popolata con i valori correnti per tale switch.
Se l'utente seleziona più switch, la finestra di dialogo Configure è vuota e i valori immessi si applicano a tutti gli switch selezionati.
image.png
Se le credenziali di accesso sono state modificate, immettere le nuove credenziali di accesso per lo switch.

Se la configurazione SNMP è cambiata, selezionare Manual SNMP Configuration e inserire le informazioni aggiornate nella finestra di
dialogo.

Cliccare su OK.Le

credenziali utilizzate da SANnav per rilevare lo switch o per la configurazione SNMP vengono modificate.
Successivamente, l'utente deve annullare il monitoraggio e quindi monitorare lo switch affinché la modifica diventi effettiva. 
 
Dopo aver eseguito i passaggi precedenti, aggiornare e controllare "SANnav Dashboard", lo stato dello switch viene visualizzato come "Healthy"
 

Affected Products

Connectrix SANnav
Article Properties
Article Number: 000224735
Article Type: Solution
Last Modified: 03 May 2024
Version:  1
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