PowerProtect: Il processo di protezione Kubernetes non riesce a creare un'istantanea del volume in uso.
Summary: Il lavoro di protezione non riesce a creare un'istantanea del volume in uso.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
I processi di protezione Kubernetes di PowerProtect Data Manager hanno esito negativo con un messaggio di errore simile al seguente:
Unable to create snapshots. Unable to snapshot PVC 'Test-pvc' in namespace 'backup-test'.
Unable to create snapshot 'backup-test-xxxx-xx-xx-xx-xx-xx-test-pvc': Snapshot Creation Error : 'Failed to check and update snapshot content: failed to take snapshot of the volume <volumeID>: "rpc error: code = Internal desc = CreateSnapshot failed with error Bad request with: [POST http://<IPAddress>:8776/v3/xxxxxxxxxxxxxxxxxxxxxxx/snapshots [IPAddress]], error message: {\"badRequest\": {\"code\": 400, \"message\": \"Invalid volume: Volume <VolumeID> status must be available, but current status is: in-use.\"}}"'
Driver CSI: OpenStack Cinder CSI
Cause
La colonna 'force-create' per la risorsa VolumeSnapshotClass è impostato su "False".
Resolution
Per creare un'istantanea dei volumi in uso, impostare l'impostazione 'force-create' per VolumeSnapshotClass su 'True'.
Ulteriori dettagli sul parametro sono disponibili nei seguenti link della documentazione per il plug-in CSI OpenStack e Cinder (ultimo controllo 21 agosto 2025):
GitHub - kubernetes/cloud-provider-openstack
OpenStack - volume snapshot
Affected Products
PowerProtect Data Manager Appliance, PowerProtect Data Manager, PowerProtect Data Manager Essentials, PowerProtect Data Manager Software, PowerProtect DM5500Article Properties
Article Number: 000225034
Article Type: Solution
Last Modified: 21 Aug 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.