VxRail : vMotion échoue avec l’erreur « Une erreur système générale s’est produite : Invalid fault »

Summary: Il s’agit d’un problème vMotion, qui échoue en raison d’une erreur générale ou d’une erreur réseau vMotion de l’hôte source, même si le port vMotion VMkernel est correctement configuré. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Échec de vMotion lors de la migration vers un ou plusieurs hôtes spécifiques.
Il y a suffisamment de ports VMkernel vMotion configurés et le ping peut aboutir.

Les erreurs suivantes s’affichent lors de la tentative de vMotion : 

A general system error occurred: Invalid fault

 The vMotion failed because the destination host did not receive data from the source host on the vMotion network. Please check your vMotion network settings and physical network configuration and ensure they are correct


vmware.log

2024-05-21T16:58:32.347Z In(05) vmx - [msg.checkpoint.migration.nodata] The vMotion failed because the destination host did not receive data from the source host on the vMotion network.  Please check your vMotion network settings and physical network configuration and ensure they are correct.
2024-05-21T16:58:32.347Z In(05) vmx - Migrate: cleaning up migration state.
2024-05-21T16:58:32.347Z In(05) vmx - VigorTransport_ServerSendResponse opID=lw189jgb-62232-auto-1c0p-h5:70028930-8b-01-fe-39c9 seq=6: Completed Bootstrap request with messages.
2024-05-21T16:58:32.347Z In(05) vmx - Migrate: Final status reported through Vigor.
2024-05-21T16:58:32.347Z In(05) vmx - MigrateSetState: Transitioning from state 12 to 0.
2024-05-21T16:58:32.347Z In(05) vmx - Msg_Post: Error
2024-05-21T16:58:32.347Z In(05) vmx - [msg.checkpoint.migration.nodata] The vMotion failed because the destination host did not receive data from the source host on the vMotion network.  Please check your vMotion network settings and physical network configuration and ensure they are correct.


hostd.log ESXi de la machine virtuelle source :

2024-05-21T16:56:37.835Z info hostd[2100617] [Originator@6876 sub=Vcsvc.VMotionSrc.7107587418190845405 opID=lw189jgb-62050-auto-1bvn-h5:70028810-9c-01-f0-63dc] ResolveCb: VMX reports needsUnregister = false for migrateType MIGRATE_TYPE_VMOTION
2024-05-21T16:56:37.835Z info hostd[2100617] [Originator@6876 sub=Vcsvc.VMotionSrc.7107587418190845405 opID=lw189jgb-62050-auto-1bvn-h5:70028810-9c-01-f0-63dc] ResolveCb: Failed with fault: (vim.fault.GenericVmConfigFault) {
-->    faultMessage = (vmodl.LocalizableMessage) [
-->       (vmodl.LocalizableMessage) {
-->          key = "msg.checkpoint.init.migration.failure",
-->          arg = (vmodl.KeyAnyValue) [
-->             (vmodl.KeyAnyValue) {
-->                key = "1",
-->                value = "195887136"
-->             },
-->             (vmodl.KeyAnyValue) {
-->                key = "2",
-->                value = "Not supported"
-->             }
-->          ],
-->          message = "Failed to initialize migration at source.  Error 0xbad0020.  Not supported."
-->       }
-->    ],
-->    reason = "Failed to initialize migration at source.  Error 0xbad0020.  Not supported.",
-->    msg = "Failed to initialize migration at source.  Error 0xbad0020.  Not supported.


Destination VM ESXi Hostd.log :

2024-05-21T16:58:32.348Z info hostd[2109598] [Originator@6876 sub=Vcsvc.VMotionDst.7107587418190845405 opID=lw189jgb-62232-auto-1c0p-h5:70028930-8b-01-fe-39c9] ResolveCb: VMX reports needsUnregister = true for migrateType MIGRATE_TYPE_VMOTION
2024-05-21T16:58:32.348Z info hostd[2109598] [Originator@6876 sub=Vcsvc.VMotionDst.7107587418190845405 opID=lw189jgb-62232-auto-1c0p-h5:70028930-8b-01-fe-39c9] ResolveCb: Failed with fault: (vim.fault.GenericVmConfigFault) {
-->    faultMessage = (vmodl.LocalizableMessage) [
-->       (vmodl.LocalizableMessage) {
-->          key = "msg.checkpoint.migration.nodata",
-->          message = "The vMotion failed because the destination host did not receive data from the source host on the vMotion network.  Please check your vMotion network settings and physical network configuration and ensure they are
correct.",

 

Cause

Cela se produit lorsque le paramètre « Migrate.Enabled » est défini sur désactivé dans les paramètres avancés.
Remarque : Ce problème peut également se produire en raison d’une adresse IP dupliquée sur votre réseau. Assurez-vous que les adresses IP de vos serveurs vCenter et de vos hôtes ESX/ESXi sont uniques.

Resolution

Pour résoudre ce problème, effectuez les opérations suivantes :
  1. Connectez vSphere ou VMware Infrastructure Client à votre vCenter Server.

  2. Sélectionnez l’hôte ESXi.

  3. Sélectionnez l’onglet Configuration.

  4. Sélectionnez Paramètres avancés sous Logiciel.

  5. Sélectionnez Migrer et définissez Migrate.Enabled sur 0.

  6. Sélectionnez OK et fermez.

  7. Sélectionnez Advanced Settings.

  8. Sélectionnez Migrer et remplacez Migrate.Enabled par 1.

  9. Sélectionnez OK, puis Close.

Remarque : Si l’erreur de paramètre non valide s’affiche après la réinitialisation de « Migrate.Enabled » sur 1, reportez-vous à la section L’exécution d’une opération vMotion ou l’ajout d’une carte réseau à une machine virtuelle échoue avec l’erreur suivante : Le module nécessaire n’est pas chargé. (2013128)Ce lien hypertexte renvoie à un site Web extérieur à Dell Technologies.

Si ces étapes ne résolvent pas le problème, essayez d’augmenter le délai d’expiration des opérations de migration réseau après l’étape 4 ci-dessus. Passez ensuite aux étapes restantes. Assurez-vous de répéter ces étapes sur l’hôte de destination.

Pour augmenter le délai d’expiration des opérations réseau de migration :

  1. Sélectionnez l’onglet Configuration.

  2. Sélectionnez Paramètres avancés sous Logiciel > Migrate.

  3. Définissez Migrate.NetTimeout sur 60 s. La valeur par défaut est 20s.

  4. Sélectionnez OK, puis Close.

Affected Products

VxRail
Article Properties
Article Number: 000225285
Article Type: Solution
Last Modified: 14 Jul 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.