PowerStore: La polarización del volumen metro falla si el servicio testigo no se reinicia después de la actualización de Java
Summary: Después de una actualización de Java en el servidor testigo, la polarización de volúmenes metro puede fallar si el servicio testigo no se ha reiniciado.
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Symptoms
Es posible que los volúmenes metro no se polarizen en ambos clústeres de PowerStore si el testigo está configurado y Java se actualizó sin un reinicio del servicio.
Esto afecta a la versión 1.0.0 del servicio testigo.
Esto afecta a la versión 1.0.0 del servicio testigo.
Cause
El servicio testigo instalado en un servidor independiente utiliza Java 11. Ciertas variables del sistema solo se leen durante el inicio del servicio.
Si el servicio no se reinicia, las solicitudes de polarización para volúmenes metro pueden fallar. Esto hace que los volúmenes metro entren en un estado de sistema degradado (offline) en ambos clústeres de PowerStore
Si el servicio no se reinicia, las solicitudes de polarización para volúmenes metro pueden fallar. Esto hace que los volúmenes metro entren en un estado de sistema degradado (offline) en ambos clústeres de PowerStore
Resolution
Dell-witness-service se reiniciará automáticamente después de una actualización de Java en una versión futura.
Después de realizar actualizaciones de Java o del sistema operativo en el servidor testigo, reinicie el servicio testigo:
sudo systemctl restart dell-witness-service
Para verificar si Java se actualizó desde el último inicio del servicio testigo, compare la versión de Java instalada con la ruta de ejecución del servicio testigo.
En este ejemplo, Java 11.0.23 está instalado y el testigo se reinició en esta versión:
Si los volúmenes metro están inactivos en los clústeres de PowerStore preferidos y no preferidos, promueva manualmente los volúmenes metro en uno de los dos clústeres.
Comuníquese con el soporte técnico de Dell para obtener orientación adicional si es necesario.
Después de realizar actualizaciones de Java o del sistema operativo en el servidor testigo, reinicie el servicio testigo:
sudo systemctl restart dell-witness-service
Para verificar si Java se actualizó desde el último inicio del servicio testigo, compare la versión de Java instalada con la ruta de ejecución del servicio testigo.
En este ejemplo, Java 11.0.23 está instalado y el testigo se reinició en esta versión:
[witness@test-pwrstr-witness01 ~]$ java -version openjdk version "11.0.23" 2024-04-16 LTS OpenJDK Runtime Environment (Red_Hat-11.0.23.0.9-2) (build 11.0.23+9-LTS) OpenJDK 64-Bit Server VM (Red_Hat-11.0.23.0.9-2) (build 11.0.23+9-LTS, mixed mode, sharing) [witness@test-pwrstr-witness01 ~]$ ps -eaf | grep witness-service-fat | grep -v grep root 1126 922 0 May10 ? 00:00:00 sudo /usr/lib/jvm/java-11-openjdk-11.0.23.0.9-3.el8.x86_64/bin/java -Xmx512m -Dsystem.ip= -jar /opt/dell-witness-service/lib/witness-service-fat.jar root 1673 1126 0 May10 ? 01:20:16 /usr/lib/jvm/java-11-openjdk-11.0.23.0.9-3.el8.x86_64/bin/java -Xmx512m -Dsystem.ip= -jar /opt/dell-witness-service/lib/witness-service-fat.jarSi el servicio en ejecución hace referencia a una versión anterior de Java, reinicie el servicio testigo.
Si los volúmenes metro están inactivos en los clústeres de PowerStore preferidos y no preferidos, promueva manualmente los volúmenes metro en uno de los dos clústeres.
PRECAUCIÓN: La promoción puede provocar daños en los datos si el sistema remoto está en línea y gestionando I/O. Si la conexión entre el sistema actual y el sistema remoto está inactiva, verifique que el sistema remoto ya no esté en línea.
Comuníquese con el soporte técnico de Dell para obtener orientación adicional si es necesario.
Affected Products
PowerStore 1000T, PowerStore 1200T, PowerStore 3000T, PowerStore 3200Q, PowerStore 3200T, PowerStore 5000T, PowerStore 500T, PowerStore 5200T, PowerStore 7000T, PowerStore 9000TProducts
PowerStore 9200TArticle Properties
Article Number: 000225384
Article Type: Solution
Last Modified: 28 May 2024
Version: 2
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