PowerStore: Metro-volumepolarisatie mislukt als de witnessservice niet opnieuw wordt gestart na de Java-update
Summary: Na een Java-update op de Witness-server kan polarisatie van metrovolumes mislukken als de witness-service niet opnieuw is gestart.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Metro-volumes kunnen mogelijk niet polariseren op beide PowerStore-clusters als Witness is geconfigureerd en Java is bijgewerkt zonder dat de service opnieuw hoeft te worden gestart.
Dit is van invloed op de Witness-service versie 1.0.0.
Dit is van invloed op de Witness-service versie 1.0.0.
Cause
De Witness-service die op een onafhankelijke server is geïnstalleerd, maakt gebruik van Java 11. Bepaalde systeemvariabelen worden alleen gelezen tijdens het opstarten van de service.
Als de service niet opnieuw wordt gestart, kunnen polarisatieverzoeken voor metrovolumes mislukken. Dit heeft tot gevolg dat de Metro Volumes op beide PowerStore clusters de status Systeem gedegradeerd (offline) krijgen
Als de service niet opnieuw wordt gestart, kunnen polarisatieverzoeken voor metrovolumes mislukken. Dit heeft tot gevolg dat de Metro Volumes op beide PowerStore clusters de status Systeem gedegradeerd (offline) krijgen
Resolution
De dell-witness-service wordt automatisch opnieuw opgestart na een java-upgrade in een toekomstige release.
Nadat u java- of OS-updates op de witness-server hebt uitgevoerd, start u de witness-service opnieuw:
sudo systemctl restart dell-witness-service
Als u wilt controleren of Java is bijgewerkt sinds de laatste start van de witnessservice, vergelijkt u de geïnstalleerde Java-versie met het uitvoeringspad van de witness-service.
In dit voorbeeld is Java 11.0.23 geïnstalleerd en is witness opnieuw gestart op deze versie:
Als de Metro-volumes op zowel de geprefereerde als niet-geprefereerde PowerStore-clusters niet beschikbaar zijn, promoveert u de Metro-volumes handmatig op een van de twee clusters.
Neem indien nodig contact op met de technische support van Dell voor aanvullende begeleiding.
Nadat u java- of OS-updates op de witness-server hebt uitgevoerd, start u de witness-service opnieuw:
sudo systemctl restart dell-witness-service
Als u wilt controleren of Java is bijgewerkt sinds de laatste start van de witnessservice, vergelijkt u de geïnstalleerde Java-versie met het uitvoeringspad van de witness-service.
In dit voorbeeld is Java 11.0.23 geïnstalleerd en is witness opnieuw gestart op deze versie:
[witness@test-pwrstr-witness01 ~]$ java -version openjdk version "11.0.23" 2024-04-16 LTS OpenJDK Runtime Environment (Red_Hat-11.0.23.0.9-2) (build 11.0.23+9-LTS) OpenJDK 64-Bit Server VM (Red_Hat-11.0.23.0.9-2) (build 11.0.23+9-LTS, mixed mode, sharing) [witness@test-pwrstr-witness01 ~]$ ps -eaf | grep witness-service-fat | grep -v grep root 1126 922 0 May10 ? 00:00:00 sudo /usr/lib/jvm/java-11-openjdk-11.0.23.0.9-3.el8.x86_64/bin/java -Xmx512m -Dsystem.ip= -jar /opt/dell-witness-service/lib/witness-service-fat.jar root 1673 1126 0 May10 ? 01:20:16 /usr/lib/jvm/java-11-openjdk-11.0.23.0.9-3.el8.x86_64/bin/java -Xmx512m -Dsystem.ip= -jar /opt/dell-witness-service/lib/witness-service-fat.jarAls de actieve service naar een oudere Java-versie verwijst, start u de witness-service opnieuw.
Als de Metro-volumes op zowel de geprefereerde als niet-geprefereerde PowerStore-clusters niet beschikbaar zijn, promoveert u de Metro-volumes handmatig op een van de twee clusters.
WAARSCHUWING: Promotie kan leiden tot beschadiging van gegevens als het externe systeem online is en I/O serveert. Als de verbinding tussen het huidige systeem en het externe systeem is verbroken, controleert u of het externe systeem niet langer online is.
Neem indien nodig contact op met de technische support van Dell voor aanvullende begeleiding.
Affected Products
PowerStore 1000T, PowerStore 1200T, PowerStore 3000T, PowerStore 3200Q, PowerStore 3200T, PowerStore 5000T, PowerStore 500T, PowerStore 5200T, PowerStore 7000T, PowerStore 9000TProducts
PowerStore 9200TArticle Properties
Article Number: 000225384
Article Type: Solution
Last Modified: 28 May 2024
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.